You are currently offline, waiting for your internet to reconnect

Unprocessed timesheets or expenses exist when attempting to delete a user in PDK

TechKnowledge Content
SYMPTOMS

I am trying to delete a user within PDK and received a message indicating this user still had an unprocessed Timesheet or expense. Unfortunately, the message did not tell me in which time period the unprocessed transaction was present.
Is there a way to generate a listing or report of all unprocessed timesheets and expenses throughout all periods?

CAUSE

An unprocessed timesheet or expense exists.

RESOLUTION

You can run the following script in Query Analyzer against the company database. You will need to fill in the Employee ID of the user you are trying to delete.

Select * from PDK10000
Where PDK_Document_Status < 8 and EMPLOYID = 'enteremployeehere'
Go
Select * from PDK10500
Where PDK_Document_Status < 8 and EMPLOYID = 'enteremployeehere'
Go

This will provide a list of timesheets and expenses that need to be deleted or processed.

This article was TechKnowledge Document ID: 33867
Properties

Article ID: 870090 - Last Review: 04/04/2016 16:24:00 - Revision: 5.0

Microsoft Dynamics GP 2010, Microsoft Dynamics GP 10.0, Microsoft Dynamics GP 9.0

  • kbnosurvey kbmbspersonaldatakeeper kbmbsmigrate KB870090
Feedback
"> y>img style="display: none; " src="https://c1.microsoft.com/c.gif?DI=4050&did=1&t="> var varCustomerTracking = 1; var Route = "76500"; var Ctrl = ""; document.write(" var Route = "76500"; var Ctrl = ""; document.write(" p;did=1&t=">