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Symptoms

When you start Microsoft Dynamics AX 4.0 Service Pack 1 (SP1) on a client computer, you receive the following error message:

Error in file: \\Microsoft Dynamics AX installation path\appl\standard\axsys.aod while reading in record = 0

Windows error: =

Error code: 64 = The specified network name is no longer available.

Try again?

Additionally, the following event is logged on the client computer:Notes

  • In this error message, the word "occured" is a misspelling for the word "occurred."

  • The file_name placeholder in the error description represents a file that resides in the shared folder that contains the program installation files.

Cause

This issue may occur if one of the following conditions is true:

  • The Application Object Server (AOS) service is stopped.

  • A power failure, a switch fault, or a hardware failure occurred that caused the connection to stop abruptly.

  • Virus scanning or backup software locked some files.

  • The network connection was lost to the shared folder that contains the program installation files.

  • Code changes were deployed while other users were using Microsoft Dynamics AX.

Note For more information about how to deploy code changes, see the Microsoft Dynamics AX Developers Guide. To view this guide, click Help, and then click Microsoft Dynamics AX Developer's Guide.

Resolution

To resolve this issue, follow these steps:

  1. Stop the AOS service. To do this, click Start, click Run, type services.msc, and then click OK. Locate the AOS service. If the service is running, right-click the service, and then click Stop.

    Note The AOS service name uses the following format:

    Dynamics Server$ instance-number AOS-instance-name

  2. Start the Support Administrator Console, Microsoft SQL Query Analyzer, or SQL Server Management Studio. To do this, use one of the following methods depending on the program that you are using.

    Method 1: For SQL Server Desktop Engine If you are using SQL Server Desktop Engine (also known as MSDE 2000), start the Support Administrator Console. To do this, click Start, point to All Programs, point to Microsoft Administrator Console, and then click Support Administrator Console.

    Method 2: For SQL Server 2000 If you are using SQL Server 2000, start SQL Query Analyzer. To do this, click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.

    Method 3: For SQL Server 2005 If you are using SQL Server 2005, start SQL Server Management Studio. To do this, click Start, point to All Programs, point to Microsoft SQL Server 2005, and then click SQL Server Management Studio.

  3. Close all the open connections to the Microsoft Dynamics AX database server.

  4. Restart the AOS service.

  5. Restart the Microsoft Dynamics AX client.

More Information

To prevent this issue, use one or more of the following methods:

  • In the AOS configuration settings, use an IP address instead of a Domain Name System (DNS) name, a mapped drive, or a hidden shared folder that contains the program installation files.

  • While the servers that are running the AOS service are connected, disable real-time virus scanning of the shared folder that contains the shared program files.

  • Incorrect configuration of the teamed network adapters may cause connection issues. Make sure that the Save Power Option setting is not enabled on the network adapter. The AOS service and the client use the first network adapter that is available. Make sure that local area network (LAN) adapters are first in the binding order before any wireless network adapters.

  • Monitor the locked files and the available files by using the computer management console on the program file server. To do this, follow these steps:

    1. Click Start, click Run, type compmgmt.msc, and then click OK.

    2. In the Computer Management console tree, click Shared Folders.

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