Symptoms
Consider the following scenario:
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You have an XML Paper Specification (XPS) document that is hosted on a Web site.
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The Web site is configured to use basic authentication or forms authentication with a session cookie.
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You run XPSViewer.exe to access the XPS document on a computer that is running .NET Framework 3.5 Service Pack 1 (SP1).
In this scenario, XPSViewer.exe crashes. Additionally, you receive the following error message:
XPSViewer.exe has encountered a problem and needs to close. We are sorry for the inconvenience.
Cause
This problem occurs because of a bug in XPSViewer.exe. This bug causes the error to occur when the XPS viewer prompts you to enter a user credential.
Resolution
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have the .NET Framework 3.5 SP1 installed to apply this hotfix.
Restart requirement
You do not have to restart the computer after you apply this hotfix if no instance of the .NET Framework is being used.
Hotfix replacement information
This hotfix does not replace other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2000, of Windows Server 2003, and of Windows XP
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Xpsviewer.exe |
3.0.6920.4008 |
298,304 |
25-Sep-2009 |
01:54 |
x86 |
Workaround
To work around this problem, use one of the following methods:
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Do not use authentication for the Web site.
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Use Integrated Windows authentication such as NTLM authentication or Kerberos authentication. Make sure that the document can be accessed without user credentials. For example, Web sites in an intranet zone or in trusted sites can be accessed without user credentials.
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Use forms authentication together with a persistent cookie.
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Use Microsoft XPS Viewer Essentials Pack (EP) instead of XPSViewer.exe to open the document.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
To obtain Microsoft XPS Essentials Pack, visit the following Microsoft Download Center Web site:
http://www.microsoft.com/download/details.aspx?FamilyId=B8DCFFDD-E3A5-44CC-8021-7649FD37FFEE