Create a UML deployment diagram

You can create a UML Deployment diagram to show the architecture of a deployment of software artifacts to nodes. First, you open the UML Deployment template and pick one of the four template options. Then the UML Deployment stencil appears, along with shapes that conform to the UML 2.5 standard.

UML Deployment stencil, example shapes on the page

Start a UML Deployment diagram

  1. Start Visio. Or if you have a file open already, click File > New.

  2. Go to Categories > Software and Database > UML Deployment.

  3. Select the blank template or one of the three starter diagrams. When you’ve picked the template you want, click Create.

  4. You should see the Shapes window next to the diagram. If you don’t see it, go to View > Task Panes and make sure that Shapes is selected. If you still don’t see it, click the Expand the Shapes window button Expand Shapes Window button on the left.

  5. On the View tab, make sure the check box next to Connection Points is selected. This will make connection points appear when you start connecting shapes.

  6. Now, drag shapes you want to include in your diagram from the Shapes window to the page. To rename text labels, double-click the labels.

Start a UML Deployment diagram

  1. Open Visio for the web. Near the upper right, select More templates.

  2. In the Gallery, scroll down to the UML Deployment row, about midway down the page.

    The first item in the row represents a blank template plus the companion stencil. The other items in the row are sample diagrams that have some shapes already drawn to help you get started quickly.

  3. Click any item to see a larger preview.

  4. When you find the diagram you want to use, click its Create button.

    The new diagram, with the related stencil, opens in your browser.

Node instances and artifacts

When to use

  1. Use Node Instance shapes when you want to specify an instance of a run-time computational or physical device.

  2. Put Artifact Instance shapes inside node instance shapes to deploy artifacts.

1 pointing to Node Instance shape "<<cloud vm>> :MachineInstance" ; 2 pointing to Artifact shape: "<<Artifact>> Number Cruncher.py"

Step 1

Drag a Node Instance shape to the page first, and then make it bigger by dragging the shape handles.

Node Instance shape resized to be larger

Step 2

Drag an Artifact Instance shape and place it inside the larger node shape. When you see a green highlight, this means the smaller shape will be contained within the larger node shape. From that point forward, when the node shape moves, the artifact inside will move as well.

Artifact shape dragged on top of Node Instance shape, green highlight

Other container shapes

There are other container shapes available in the UML Deployment stencil. They behave like the Node Instance shape. That is, when you drop shapes on top of them, the shapes are glued and will move with the container. Here are some of the most popular container shapes for deployment diagrams:

Hierarchical nodes

Nest node shapes inside each other when you want to show them hierarchically.

UserClient node, containing Browser node which contains the HTML5 artifact

Package shapes

Use Package shapes when you need to represent containing elements like a folder.

Package shape containing other node instance and artifact shapes

Diagram Overview

Use the Diagram Overview shape when you want to surround all of the shapes with a frame.

Diagram overview shape containing other node instance and artifact shapes

Tips for connectors

Straighten connectors

If a connector is taking too many turns, right-click it, and then click Straight Connector.

Show multiplicity

If needed, right-click the connector and select Show Multiplicity. When you’re done, four text boxes appear where you can add details. If you do not need all the text boxes, delete the ones you don’t need.

Change connector type

You can change a connector type. For example, you can change from an Association to a Directed Association. Right-click the connector, and then click Set Connector Type.

Make dynamic connections instead of point connections

If you anticipate moving shapes a lot, consider making a dynamic connection instead of a point connection.

Move or rotate text on connectors

Most likely you’ll need to rotate or move text on your connector lines. Here’s how to do that:

  1. Click an empty area of the page to deselect anything that may be selected.

  2. On the Home tab, in the Tools group, click the Text Block tool Text Block button

  3. Click the connector that has text your want to rotate or move.

  4. Drag the text block to move it, or rotate it using the Rotation Handle Rotation handle

  5. When you’re done, click the Pointer Tool button Pointer button

    After you switch back to the Pointer Tool button Pointer button , the text keeps the same position relative to the shape. If you use the Pointer Tool Pointer button to drag the text, the shape will also move. To move the text independently of the shape, go back to the Text Block Tool Text Block button .

Component shapes

When to use

Use component shapes for each functional unit in your system or application.

"Store" component shape

Show or hide stereotype

Right-click the shape to show or hide the stereotype label.

Right-click menu, Show Stereotype command, <<component>> text label

Interface shapes

When to use

  1. Use the Provided Interface shape when you want to specify the realization of a class/interface.

  2. Use the Required Interface when you want to specify a dependency on a class/interface.

Two interfaces connected, 1: Provided Interface shape ending with circle, 2: Required Interface shape ending with socket

Step 1

Drag a Provided Interface shape to the page, and line up the port square with a connection point. You know it’s connected when you see the green highlight around the connection point.

Provided Interface shape glued to Component shape

Step 2

Drag a Required Interface shape to the page, and line up the port square with a connection point as well. You know it’s connected when you see the green highlight around the connection point.

Required Interface shape glued to Component shape

Step 3

To connect both a Provided and Required interface together, first select the Required Interface shape. Then look for the yellow handle.

Yellow handle on the Required Interface shape

Step 4

Drag the yellow handle to connect with the Provided Interface.

Required Interface shape connected to Provided Interface

See Also

UML diagrams in Visio

Create a UML component diagram

Create a UML communication diagram

Create a UML sequence diagram

Need more help?

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

×