Create a UML use case diagram

You can create a UML use case diagram in Visio to summarize how users (or actors) interact with a system, such as a software application. An actor can be a person, an organization, or another system.

Use case diagrams show the expected behavior of the system. They don't show the order in which steps are performed. (Use a sequence diagram to show how objects interact over time.)

A sample of a UML use case diagram showing referee certification system

Defining the system boundary determines what is considered external or internal to the system.

An actor represents a role played by an outside object. One object may play several roles and, therefore, is represented by several actors.

An association illustrates the participation of the actor in the use case.

A use case is a set of events that occurs when an actor uses a system to complete a process. Normally, a use case is a relatively large process, not an individual step or transaction.

Create a new use case diagram

  1. On the File tab, point to New.

  2. in the Search box, type UML use case.

  3. From the search results, select UML Use Case.

  4. In the dialog box, select the blank template or one of the three starter diagrams. (A description of each one is shown on the right when you select it.) Then select either Metric Units or US Units.

  5. Select Create.

  6. The diagram opens. You should see the Shapes window next to the diagram. A UML Use Case stencil is open in the Shapes window.

    (If you don’t see the Shapes window, go to View > Task Panes and make sure that Shapes is selected. If you still don’t see it, click the Expand the Shapes window button on the left.)

Add a subsystem to the use case diagram

  1. Drag a Subsystem shape onto the drawing page. The subsystem can represent your entire system or a major component.

    The Subsystem shape.

  2. Double-click the Subsystem shape, and then type a new name for the for it, or press the Delete key to delete the existing name. Click outside the shape on the drawing page.

  3. To resize the subsystem, select the shape, and then drag a selection handle.

Add shapes and connectors to the diagram

  1. Drag Use Case shapes The Use Case shape. from the UML Use Case stencil and place them inside the subsystem boundary, and then drag Actor shapes The Actor shape. to the outside of the subsystem boundary.

  2. Use connector shapes to indicate relationships between shapes in the diagram. There are five connectors available:

    Connector

    Description

    Association

    The Association connector.

    Shows the relationship of an actor to a use case.

    Dependency

    The Dependency connector.

    Indicates that one use case has a dependency on another.

    Generalization

    The Generalization connector.

    Indicates that a use case is a specific way to achieve goals of the general use case.

    Include

    The Include connector.

    Shows how a use case is broken into smaller steps.

    Extend

    The Extend connector.

    Shows that one use case adds functionality to another.

    Example: To indicate a relationship between an actor and a use case

    1. In a use case diagram, drag an Association connector shape onto the drawing page.

    2. Glue one endpoint of the Association shape to a connection point on an Actor shape. Glue the other endpoint to a connection point on a Use Case shape.

See Also

For more information about use case diagrams (and procedures for using Microsoft Visual Studio to create use case diagrams), go to UML Use Case Diagrams: Guidelines.

Create a new use case diagram

  1. Open Visio for the web.

  2. In the Gallery, scroll down to the UML Use Case row, about midway down the page.

    The first item in the row represents a blank template plus the companion stencil. The other items in the row are sample diagrams that have some shapes already drawn to help you get started quickly.

  3. Click any item to see a larger preview.

  4. When you find the diagram you want to use, click its Create button.

    The new diagram, with the related stencil, opens in your browser.

Add a subsystem to the use case diagram

  1. Drag a Subsystem shape onto the drawing page. The subsystem can represent your entire system or a major component.

    The Subsystem shape.

  2. Double-click the Subsystem shape, and then type a new name for the for it, or press the Delete key to delete the existing name. Click outside the shape on the drawing page.

  3. To resize the subsystem, select the shape, and then drag a selection handle.

Add shapes and connectors to the diagram

  1. Drag Use Case shapes The Use Case shape. from the Use Case stencil and place them inside the subsystem boundary

  2. Drag Actor shapes The Actor shape. to the outside of the subsystem boundary.

  3. Use connector shapes to indicate relationships between shapes in the diagram. There are five connectors available:

    Connector

    Description

    Association

    The Association connector.

    Shows the relationship of an actor to a use case.

    Dependency

    The Dependency connector.

    Indicates that one use case has a dependency on another.

    Generalization

    The Generalization connector.

    Indicates that a use case is a specific way to achieve goals of the general use case.

    Include

    The Include connector.

    Shows how a use case is broken into smaller steps.

    Extend

    The Extend connector.

    Shows that one use case adds functionality to another.

    Example: To indicate a relationship between an actor and a use case

    1. In a use case diagram, drag an Association connector shape onto the drawing page.

    2. Glue one endpoint of the Association shape to a connection point on an Actor shape. Glue the other endpoint to a connection point on a Use Case shape.

  4. Visio for the web saves automatically. To rename a drawing, double-click to select the default name (such as Drawing1) at the top of the drawing and then type a new name over it.

See Also

For more information about use case diagrams (and procedures for using Microsoft Visual Studio to create use case diagrams), go to UML Use Case Diagrams: Guidelines.

Create a new use case diagram

  1. On the File tab, point to New.

  2. in the Search box, type UML use case.

  3. From the search results, select UML Use Case.

  4. In the dialog box, select the blank template. Then select either Metric Units or US Units.

  5. Select Create.

  6. The diagram opens. You should see the Shapes window next to the diagram. A UML Use Case stencil is open in the Shapes window.

    (If you don’t see the Shapes window, go to View > Task Panes and make sure that Shapes is selected. If you still don’t see it, click the Expand the Shapes window button on the left.)

Add a subsystem to the use case diagram

  1. Drag a Subsystem shape onto the drawing page. The subsystem can represent your entire system or a major component.

  2. Double-click the Subsystem shape, and then type a new name for the for it, or press the Delete key to delete the existing name. Click outside the shape on the drawing page.

  3. To resize the subsystem, select the shape, and then drag a selection handle.

Add shapes and connectors to the diagram

  1. Drag Use Case shapes from the UML Use Case stencil and place them inside the subsystem boundary, and then drag Actor shapes to the outside of the subsystem boundary.

  2. Use connector shapes to indicate relationships between shapes in the diagram. There are five connectors available:

    Connector

    Description

    Association

    Shows the relationship of an actor to a use case.

    Dependency

    Indicates that one use case has a dependency on another.

    Generalization

    Indicates that a use case is a specific way to achieve goals of the general use case.

    Include

    Shows how a use case is broken into smaller steps.

    Extend

    Shows that one use case adds functionality to another.

    Example: To indicate a relationship between an actor and a use case

    1. In a use case diagram, drag an Association connector shape onto the drawing page.

    2. Glue one endpoint of the Association shape to a connection point on an Actor shape. Glue the other endpoint to a connection point on a Use Case shape.

See Also

For more information about use case diagrams (and procedures for using Microsoft Visual Studio to create use case diagrams), go to UML Use Case Diagrams: Guidelines.

  1. On the File tab, point to New.

  2. Under Template Categories, click Software and Database.

    Select Software and Database

  3. Click UML Model Diagram. A blank drawing page appears.

    Select UML Model Diagram

  4. In the tree view, right-click the package or subsystem in which you want to include a use case diagram, then point to New, and then click Use Case Diagram.

    Click Use Case Diagram

    A blank page appears, and the UML Use Case stencil becomes the top-most stencil. An icon representing the diagram is added to the tree view.

    Use case is added to tree view

    Note: If the tree view is not visible, on the UML tab, in the Show/Hide group, select Model Explorer.

  5. To indicate a System Boundary in a use case diagram

    1. Drag a System Boundary shape onto the drawing page.

      Select System Boundary

    2. Double-click the System Boundary shape, and then type a new name for the system or press the DELETE key to delete the existing name. Click outside the shape on the drawing page.

    3. To resize the system boundary, select the shape, and then drag a selection handle.

  6. Drag Use Case shapes from the Use Case stencil and place them inside the system boundary, and then drag Actor shapes to the outside of the system boundary.

  7. Use Communicates shapes to indicate relationships between use cases and actors.

    To indicate a relationship between an actor and a use case

    1. In a use case diagram, drag a Communicates shape onto the drawing page.

    2. Glue one endpoint End point image, which is plus sign in a green square of the Communicates shape to a connection point Connection point image - blue X on an Actor shape. Glue the other endpoint to a connection point on a Use Case shape.

    3. If you want to add an arrow to indicate the flow of information, do the following:

      • Double-click the Communicates shape, then, under Association, click the end you want to edit, and then click Properties.

      • In the Association End category, check IsNavigable, click OK, then click OK again.

      • Right-click the Communicates shape and click Shape Display Options. Under End options, select End navigability, and then click OK.

  8. Use Uses and Extends shapes to indicate the relationships between use cases.

    To indicate a uses relationship between two use cases

    1. In a use case diagram, drag a Uses relationship shape onto the drawing page.

    2. Glue the Uses endpoint without an arrowhead to a connection point Connection point image - blue X on the Use Case shape that uses the behavior of the other use case.

    3. Glue the Uses endpoint (with an arrowhead) to a connection point on the use case being used.

    4. Double-click the Uses shape to open the UML Generalization Properties dialog box. Add property values, and then click OK.

    To indicate an extends relationship between two use cases

    1. In a use case diagram, drag an Extends shape onto the drawing page.

    2. Glue the Extends endpoint End point image, which is plus sign in a green square without an arrowhead to a connection point Connection point image - blue X on the use case providing the extension.

    3. Glue the Extends endpoint with an arrowhead to a connection point on the base use case.

    4. Double-click the Extends shape to open the UML Generalization Properties dialog box. Add the property values, and then click OK.

  9. Double-click any shape (except the System Boundary shape) to open its UML Properties dialog box where you can add a name, attributes, operations, and other property values.

  10. Save the diagram.

  1. On the File menu, point to New, point to Software and Database, and then click UML Model Diagram.

    Select Software and Database

  2. In the tree view, right-click the package or subsystem in which you want to include a use case diagram, point to New, and then click Use Case Diagram.

    Selece Use Case Diagram

    A blank page appears, and the UML Use Case stencil becomes the top-most stencil. An icon representing the diagram is added to the tree view.

    Note: If the tree view is not visible, on the UML menu, point to View, and then click Model Explorer.

  3. To indicate a system boundary in a use case diagram

    1. Drag a System Boundary shape onto the drawing page.

      Use Case Stencil

    2. Double-click the System Boundary shape, and then type a new name for the system or press the DELETE key to delete the existing name. Click outside the shape on the drawing page.

    3. To resize the system boundary, select the shape, and then drag a selection handle.

  4. Drag Use Case shapes from the Use Case stencil and place them inside the system boundary, and then drag Actor shapes to the outside of the system boundary.

  5. Use Communicates shapes to indicate relationships between use cases and actors.

    To indicate a relationship between an actor and a use case

    1. In a use case diagram, drag a Communicates shape onto the drawing page.

    2. Glue one endpoint End point image, which is plus sign in a green square of the Communicates shape to a connection point Connection point image - blue X on an Actor shape. Glue the other endpoint to a connection point on a Use Case shape.

    3. If you want to add an arrow to indicate the flow of information, do the following:

      • Double-click the Communicates shape, then, under Association, click the end you want to edit, and then click Properties.

      • In the Association End category, check IsNavigable, click OK, then click OK again.

      • Right-click the Communicates shape and click Shape Display Options. Under End options, select End navigability, and then click OK.

  6. Use Uses and Extends shapes to indicate the relationships between use cases.

    To indicate a uses relationship between two use cases

    1. In a use case diagram, drag a Uses relationship shape onto the drawing page.

    2. Glue the Uses endpoint without an arrowhead to a connection point Connection point image - blue X on the Use Case shape that uses the behavior of the other use case.

    3. Glue the Uses endpoint (with an arrowhead) to a connection point on the use case being used.

    4. Double-click the Uses shape to open the UML Generalization Properties dialog box. Add property values, and then click OK.

    To indicate an extends relationship between two use cases

    1. In a use case diagram, drag an Extends shape onto the drawing page.

    2. Glue the Extends endpoint End point image, which is plus sign in a green square without an arrowhead to a connection point Connection point image - blue X on the use case providing the extension.

    3. Glue the Extends endpoint with an arrowhead to a connection point on the base use case.

    4. Double-click the Extends shape to open the UML Generalization Properties dialog box. Add the property values, and then click OK.

  7. Double-click any shape (except the System Boundary shape) to open its UML Properties dialog box where you can add a name, attributes, operations, and other property values.

  8. Save the diagram.

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×