In many cases, you can prevent these security warnings by installing antivirus software and making sure that it is updated regularly. This article describes why the security warnings appear and what the conditions must be to not get them.

Tip:  Microsoft provides free antivirus software, Microsoft Security Essentials and Windows Defender. These features provide real-time protection for your computer to help guard against viruses, spyware, and other malicious software.

In this article

Symptoms

One of the following security warnings appear:

  • A program is trying to access e-mail address information stored in Outlook. If this is unexpected, click Deny and verify your antivirus software is up-to-date.

  • A program is trying to send an e-mail message on your behalf. If this is unexpected, click Deny and verify your antivirus software is up-to-date.

  • A program is trying to perform an action that may result in an e-mail message being sent on your behalf. If this is unexpected, click Deny and verify your antivirus software is up-to-date.

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Cause

These security warnings appear when a program attempts to access your contact information in the Outlook Address Book, or attempts to send email on your behalf. By default, only COM add-ins are trusted programs. Your email administrator may have allowed specific add-ins by adding them to a "Trusted add-ins" list. Any other program isn’t trusted, and a security warning appears because of the potential risk that the program is malicious and designed to use Outlook to spread viruses. Before this safeguard was established, viruses were able to access Outlook and spread by sending messages to the people listed in Contacts.

Programs that start automatically    It is possible that the program started automatically. For example, a program tries to automatically send an email message by using the Item.Send method in the Outlook object model.

Programs that you start    It is also possible that you started the program. For example, you are using a program to synchronize your PDA or mobile device with Outlook data.

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Resolution

Resolve this security warning

  • If you didn’t expect a program to access Outlook, or if you aren’t sure whether the program that is trying to access Outlook is trustworthy, click Deny.

  • If you clicked a command or started a program that you know is supposed to access Outlook data or send email messages using Outlook, and you consider the program to be trustworthy, do one of the following:

    • Click Allow.

    • If you are prompted to allow access to recipient information, select the Allow access for check box, click how long that you want to grant access for, and then click Allow.

      Note:  You should choose the least time that is needed for the other program to access your Outlook data. If the program needs additional time, the security warning will appear again.

Prevent this security warning from appearing again

Tip:  Microsoft provides free antivirus software, Microsoft Security Essentials and Windows Defender. These features provide real-time protection for your computer to help guard against viruses, spyware, and other malicious software.

Under certain conditions, installing an antivirus program and keeping it updated regularly might prevent this security warning from appearing again. The conditions are as follows:

  • Your antivirus software must be updated regularly. Most antivirus software enables you to download automatic updates when you are online. Check with your antivirus software vendor.

  • Your antivirus software is configured to share its update status with other applications. Typically, antivirus programs share their update status with other applications. To check the update status setting, look in the preferences or options for your antivirus program, or check with your antivirus software vendor.

    Notes: 

    • Outlook relies on the Windows Security Center to check for the presence of the antivirus software and update its status.

    • If your antivirus software subscription expires or is inactive, you might get the security warning again when a program tries to access Outlook.

View security settings in the Trust Center

The Programmatic Access security settings in the Trust Center provide the following options:

  • Warn me about suspicious activity when my antivirus software is inactive or out-of-date (recommended)      This is the default setting in Outlook. Suspicious activity refers to an untrusted program that is trying to access Outlook.

  • Always warn me about suspicious activity      This is the most secure setting and you’l always be prompted to make a trust decision when a program attempts to access Outlook.

  • Never warn me about suspicious activity (not recommended)      This is the least secure setting.

To view these settings, do the following:

  1. Click the File tab.

  2. Click Options.

  3. Click Trust Center.

  4. Click Trust Center Settings.

  5. Click Programmatic Access.

    Notes: 

    • If your computer is managed by a Microsoft Exchange Server administrator or a Microsoft Windows Active Directory Domain Services administrator in your organization, and the administrator changes the default setting and prevents users from making changes, the option to customize the Programmatic Access security settings is disabled.

    • If your computer isn’t managed by an Exchange Server administrator or a Microsoft Windows Active Directory Domain Services administrator, and you are the Windows administrator of your computer, you can change the Programmatic Access security settings. However, we don’t recommend this.

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