Supported browsers for Outlook on the web and Outlook.com

Supported browsers for Outlook on the web and Outlook.com

Not all web browsers support Outlook on the web or Outlook.com, and some browsers will have problems loading Outlook.com if ad blockers or pop-up blockers are enabled.

Supported browsers

Use the most recent versions of the following browsers for the best experience with Outlook on the web and Outlook.com. If you're using an old browser, you'll see the light version of Outlook.

Windows 10: Microsoft Edge, Internet Explorer 11, Mozilla Firefox, or Google Chrome

Windows 8, 8.1, or 7 (SP1): Internet Explorer 11, Firefox or Chrome

Windows Vista (SP2): Firefox or Chrome, but some features may not be available. We recommend updating to at least Windows 7 (SP1).

Mac OS X (10.10 and later): Apple Safari 10+ or Chrome

Linux:Outlook.com and Outlook on the web work in both Firefox or Chrome on Linux, but some features may not be available.

Mobile browser requirements

Most mobile browsers will work with Outlook on the web and Outlook.com. Make sure you keep your mobile device and its apps up to date.

  • A phone or tablet with Android 5.0 or later.

  • An iPhone, iPad, or iPod touch with iOS 10.0 or later.

  • A phone running Windows Phone 7.5 or later.

Unsupported web browsers and plugins

Some browsers will have problems with Outlook.com if ad blockers or pop-up blockers are enabled, specifically:

  • AdBlock

  • Ublock

Learn how to manage browser extensions in Microsoft EdgeInternet ExplorerFirefoxChrome, or Safari.

System requirements

Account

Outlook.com requires an active Microsoft account. For help with creating a Microsoft account or signing in, see Microsoft account help.

Minimum operating system

Ideally, you should use the latest operating system available for your device. This will support the most features and provide better security than earlier versions.

  • Windows 10, Windows 8/8.1, or Windows 7.

  • Windows Vista (SP2) with Firefox or Chrome, but some features may not be available. We recommend updating to at least Windows 7 (SP1).

  • Mac OS X 10.10 or later.

  • Linux: Outlook.com works in both Firefox and Chrome on Linux, but some features may not be available.

  • Windows Server 2016, Windows Server 2012 (including R2), Windows Server 2008 R2, or Windows Server 2008 with Service Pack 2 and the Platform Update for Windows Server 2008.

Processor: 1.6 GHz or higher, or Intel-based Mac computer

Memory: 1 GB of RAM or higher

Resolution: 1024 × 768 minimum

Internet connection: High-speed internet access is recommended.

Still need help?

For more information about resolving issues, visit Fixes or workarounds for recent issues on Outlook.com, or use the buttons below to visit the community forums or contact support.

Note: You will need to sign in first to get support. If you can't sign in, go to Account support.

You can also try the Microsoft Virtual Agent.

Expand your Office skills
Explore training
Get new features first
Join Office Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×