Applies ToWindows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition

Symptoms

Assume that you run the Device Fundamental tests on a computer that is running Windows 7 or Windows Server 2008 R2, and then you use certain network adapters. In this situation, the system crashes. Additionally, you receive a Stop error message that resembles the following:

Stop 0x000000C4 (parameter1, parameter2, parameter3, parameter4)

Notes

  • This Stop error describes a DRIVER_VERIFIER_DETECTED_VIOLATION issue.

  • The parameters in this error message vary, depending on the configuration of the computer.

  • Not all "0x000000C4" Stop errors are caused by this issue.

  • The following devices are known to be affected by this issue:

    • Realtek WLAN device RTL8191SE device

    • Atheros WLAN device - AR5007EG

    • Realtek RTL8192SU Wireless LAN 802.11n USB 2.0 Network Adapter

Cause

This issue is caused by a deadlock scenario in the Netio.sys driver. The deadlock scenario occurs when an endpoint is deleted and when an endpoint is added at the same time.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 Service Pack 1 (SP1).For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 1.22xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Fwpkclnt.sys

6.1.7601.22015

187,760

09-Jun-2012

04:33

Tcpip.sys

6.1.7601.22015

1,306,480

09-Jun-2012

04:33

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Fwpkclnt.sys

6.1.7601.22015

288,624

09-Jun-2012

05:32

Tcpip.sys

6.1.7601.22015

1,901,424

09-Jun-2012

05:32

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Fwpkclnt.sys

6.1.7601.22015

483,184

09-Jun-2012

04:32

Tcpip.sys

6.1.7601.22015

3,812,208

09-Jun-2012

04:32

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updatesThe third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

X86_70ef39b41711394c77f229e2fa623e92_31bf3856ad364e35_6.1.7601.22015_none_5ad6e196b5446cf7.manifest

File version

Not applicable

File size

702

Date (UTC)

09-Jun-2012

Time (UTC)

09:56

File name

X86_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7601.22015_none_b5aff726ddc53dd9.manifest

File version

Not applicable

File size

3,834

Date (UTC)

09-Jun-2012

Time (UTC)

05:07

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

Amd64_b89c43ff84c23d2c410497f9669cf7d5_31bf3856ad364e35_6.1.7601.22015_none_064c9f32f32f1efa.manifest

File version

Not applicable

File size

706

Date (UTC)

09-Jun-2012

Time (UTC)

09:56

File name

Amd64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7601.22015_none_11ce92aa9622af0f.manifest

File version

Not applicable

File size

3,838

Date (UTC)

09-Jun-2012

Time (UTC)

06:13

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_a3378dfe9663dbe6ce1deb6a5392911a_31bf3856ad364e35_6.1.7601.22015_none_68c2f6d44bd074f0.manifest

File version

Not applicable

File size

704

Date (UTC)

09-Jun-2012

Time (UTC)

09:56

File name

Ia64_microsoft-windows-tcpip-binaries_31bf3856ad364e35_6.1.7601.22015_none_b5b19b1cddc346d5.manifest

File version

Not applicable

File size

3,836

Date (UTC)

09-Jun-2012

Time (UTC)

05:44

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