Applies ToWindows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Standard Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Datacenter

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Symptoms

Consider the following scenario:

  • You install the Hyper-V role on a computer that is running Windows Server 2008 R2 Service Pack 1 (SP1) and that has Intel Xeon processors.

  • You create a virtual machine (VM) that is running version 5 or 6 of the Red Hat Enterprise Linux (RHEL) operating system.

  • You select the Migrate to a physical computer with a different processor version check box under the Processor configuration for the VM.

  • You start the VM.

In this scenario, the computer crashes. Additionally, you receive a Stop error message that resembles the following:

STOP: 0x20001 (parameter1 , parameter2 , parameter3 , parameter4 ) HYPERVISOR_ERROR

Notes

  • The parameters in this Stop error message vary, depending on the configuration of the computer.

  • Not all "0x20001" Stop errors are caused by this issue.

Cause

During early initialization of a Linux VM, the hypervisor fails while it runs an XRSTOR instruction. The hypervisor may fail after the virtual processor is created or when a virtual processor is scheduled on a particular logical processor if no other virtual processor runs before the scheduled virtual processor.This issue is not specific to Linux VMs and may occur on Windows VMs. However, the 0x20001 Stop error is not generated when you start the Windows VM. This error is instead randomly generated after several days, weeks, or months of uptime.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, the Hyper-V role must be installed.For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.1.760 1. 21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Hvax64.exe

6.1.7601.21726

614,912

12-May-2011

02:27

x64

Hvboot.sys

6.1.7601.21726

118,144

12-May-2011

05:20

x64

Hvix64.exe

6.1.7601.21726

652,800

12-May-2011

02:27

x64

Workaround

To work around this issue, click to clear the Migrate to a physical computer with a different processor version check box under the Processor configuration for the VM.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updatesThe third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_0b4aaa25b4c7c95b915efe835695e509_31bf3856ad364e35_6.1.7601.21726_none_2b3a5ece1482c7d3.manifest

File version

Not applicable

File size

710

Date (UTC)

12-May-2011

Time (UTC)

08:31

Platform

Not applicable

File name

Amd64_microsoft-hyper-v-drivers-hypervisor_31bf3856ad364e35_6.1.7601.21726_none_8ef828299548bd88.manifest

File version

Not applicable

File size

4,163

Date (UTC)

12-May-2011

Time (UTC)

07:10

Platform

Not applicable

File name

Update.mum

File version

Not applicable

File size

1,462

Date (UTC)

12-May-2011

Time (UTC)

08:31

Platform

Not applicable

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