"Macros have been disabled" warning message when you start Office Word 2007 in Windows Vista or Windows 7

Symptoms

Assume that you have a Normal.dotm template file that contains a macro on a computer that is running Windows Vista or Windows 7. When you start Microsoft Office Word 2007, you receive the following warning message:

Macros have been disabled.

Cause

This issue occurs because the default template path for the Normal.dotm file is changed to C:\Users\<User Name>\Application Data\Microsoft\Templates in Windows Vista and Windows 7.

Workaround

To resolve this issue, follow these steps:


Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows

  1. Click Start, click Run, type regedit in the Open box, and then click OK.

  2. Locate and then select the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Security\Trusted Locations

  3. On the Edit menu, point to New, click key, type Location<number>, then press ENTER.

    Note The number that you should use to name the Location<number> subkey depends on the current state of your registry. For example, if the Location0, Location1, and Location2 subkeys are already present under Trusted Locations, then you should name the subkey Location3.

  4. Locate and then select the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Security\Trusted Locations\Location<number>

  5. On the Edit menu, point to New, click Expandable String Value, type Path, then press ENTER.

  6. In the Details pane, right-click Path, and then click Modify.

  7. In the Value data box, type value %APPDATA%\Microsoft\Templates, and then click OK.

  8. Exit Registry Editor.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×