Applies ToDynamics NAV 2009

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

Symptoms

When you print multiple classic reports from the RoleTailored client (RTC) in Microsoft Dynamics NAV 2009 Service Pack 1 (SP1), you receive the following error message:

You cannot use the file C:\Users\User\AppData\Roaming\fin.zup because it is already in use.

This problem occurs if the following conditions are true:

  • The reports do not have a layout defined. Therefore, the reports are run under the classic report engine from the RTC.

  • At least two reports are printed in quick succession.

Cause

This problem occurs because the RTC start the classic report engine to run a report. When a report is printed, the classic engine tries to save the .zup file. If multiple reports are started in quick succession, multiple classic engines will overwrite the other .zup files.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft Web site:

https://mbs.microsoft.com/support/newstart.aspx You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft Web sites:Partners

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+ContactsCustomers

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.

How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix, a hyperlink will be sent to you in an e-mail. The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password. If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. Then, you must provide the password provided in the e-mail.If you click Cancel, the download process stops.

How to install a Microsoft Dynamics NAV hotfix or an update file

The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files. To do this, follow these steps.

Step 1: Replace the files in the Microsoft Dynamics NAV Classic Client installation

In the Microsoft Dynamics NAV Classic Client installation, replace the following files by using the hotfix or the update file.

File name

File version

File size

Date

Time

Platform

Dbm.dll

6.0.31587.0

427,848

30-Aug-2010

16:28

x86

Fin.exe

6.0.31587.0

12,632,904

30-Aug-2010

16:28

x86

Finhlink.exe

6.0.31587.0

452,432

30-Aug-2010

16:28

x86

Finsql.exe

6.0.31587.0

12,754,768

30-Aug-2010

16:28

x86

Nc_netb.dll

6.0.31587.0

96,592

30-Aug-2010

16:28

x86

Nc_tcp.dll

6.0.31587.0

98,640

30-Aug-2010

16:28

x86

Nc_tcps.dll

6.0.31587.0

141,136

30-Aug-2010

16:28

x86

Ndbcs.dll

6.0.31587.0

1,350,480

30-Aug-2010

16:28

x86

Slave.exe

6.0.31587.0

152,400

30-Aug-2010

16:28

x86

To replace the existing Microsoft Dynamics NAV files, follow these steps:

  1. Close the Microsoft Dynamics NAV Classic Client.

  2. Locate the Microsoft Dynamics NAV Classic Client installation directory. The Microsoft Dynamics NAV Classic Client is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Classic Client installation directory.

  5. Click Yes to overwrite the files in the directory.

Step 2: Replace the files in the Microsoft Dynamics NAV RoleTailored client installation

In the Microsoft Dynamics NAV RoleTailored client installation, replace the following files by using the hotfix or the update file.

File name

File version

File size

Date

Time

Platform

Microsoft.dynamics.framework.patterns.dll

1.3.10803.301

71,656

23-Aug-2010

06:30

x86

Microsoft.dynamics.framework.ui.dll

1.3.10803.301

698,328

23-Aug-2010

06:30

x86

Microsoft.dynamics.framework.ui.mapping.dll

1.3.10803.301

104,424

23-Aug-2010

06:30

x86

Microsoft.dynamics.framework.ui.navigation.dll

1.3.10803.301

34,800

23-Aug-2010

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.dll

1.3.10803.301

88,040

23-Aug-2010

06:30

x86

Microsoft.dynamics.framework.ui.ux2006.winforms.dll

1.3.10803.301

63,480

23-Aug-2010

06:30

x86

Microsoft.dynamics.framework.ui.windows.dll

1.3.10803.301

83,944

23-Aug-2010

06:30

x86

Microsoft.dynamics.framework.ui.winforms.controls.dll

1.3.10803.301

2,115,584

23-Aug-2010

06:30

x86

Microsoft.dynamics.framework.ui.winforms.dll

1.3.10803.301

694,248

23-Aug-2010

06:30

x86

Microsoft.dynamics.nav.client.builder.dll

6.0.31587.0

198,544

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.client.exe

6.0.31587.0

149,376

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.client.interop.communicator.dll

1.0.559.183

75,688

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.client.serviceconnection.dll

6.0.31587.0

104,352

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.client.ui.dll

6.0.31587.0

509,824

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.client.winforms.dll

6.0.31587.0

341,904

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.client.winforms.tlb

Not applicable

2,680

30-Aug-2010

12:11

Not applicable

Microsoft.dynamics.nav.language.dll

6.0.31587.0

2,000,768

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.types.dll

6.0.31587.0

567,160

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.watson.dll

6.0.31587.0

42,880

30-Aug-2010

16:10

x86

Microsoft.office.interop.outlook.dll

10.0.4504.0

395,136

30-Aug-2010

16:28

x86

To replace these files, follow these steps:

  1. Close the Microsoft Dynamics NAV RoleTailored client.

  2. Locate the Microsoft Dynamics NAV RoleTailored client installation directory. The Microsoft Dynamics NAV RoleTailored client is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV RoleTailored client installation directory.

  5. Click Yes to overwrite the files in the directory.

Step 3: Replace the files in the Microsoft Dynamics NAV Server installation

In the Microsoft Dynamics NAV Server installation, replace the following files by using the hotfix or the update file.

File name

File version

File size

Date

Time

Platform

Httpcfg.exe

5.2.3790.0

22,352

30-Aug-2010

16:28

x86

Microsoft.dynamics.nav.language.dll

6.0.31587.0

2,000,768

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.ncl.dll

6.0.31587.0

608,120

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.server.exe

6.0.31587.0

141,184

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.service.dll

6.0.31587.0

145,280

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.service.runtime.dll

6.0.31587.0

75,664

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.service.webservices.dll

6.0.31587.0

145,304

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.types.dll

6.0.31587.0

567,160

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.watson.dll

6.0.31587.0

42,880

30-Aug-2010

16:10

x86

Nclcsrt.etx

Not applicable

89,525

30-Aug-2010

08:31

Not applicable

Nclcsrt.stx

Not applicable

91,724

30-Aug-2010

08:31

Not applicable

Nclcsrts.dll

6.0.31587.0

1,485,648

30-Aug-2010

16:27

x86

Ndbcs.dll

6.0.31587.0

1,350,480

30-Aug-2010

16:27

x86

To replace these files, follow these steps:

  1. Stop the Microsoft Dynamics NAV Server.

  2. Locate the Microsoft Dynamics NAV Server installation directory. The Microsoft Dynamics NAV Server is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Server installation directory.

  5. Click Yes to overwrite the files in the directory.

  6. Start the Microsoft Dynamics NAV Server.

Step 4: Replace the files in the Microsoft Dynamics NAV Application Server installation

If you have Microsoft Dynamics NAV Application Server installed, replace the following files in the Microsoft Dynamics NAV Application Server installation by using the hotfix or the update files.

File name

File version

File size

Date

Time

Platform

Dbm.dll

6.0.31587.0

427,848

30-Aug-2010

16:28

x86

Nas.exe

6.0.31587.0

2,271,560

30-Aug-2010

16:28

x86

Nassql.exe

6.0.31587.0

2,370,384

30-Aug-2010

16:28

x86

Ndbcs.dll

6.0.31587.0

1,350,480

30-Aug-2010

16:28

x86

Slave.exe

6.0.31587.0

152,400

30-Aug-2010

16:28

x86

To replace the files, follow these steps.

  1. Stop the Microsoft Dynamics NAV Application Server.

  2. Locate the Microsoft Dynamics NAV Application Server installation directory. The Microsoft Dynamics NAV Application Server is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the Microsoft Dynamics NAV Application Server installation directory.

  5. Click Yes to overwrite the files in the directory.

  6. Start the Microsoft Dynamics NAV Application Server.

Step 5: Replace the files in the Microsoft Dynamics NAV SDK installation

If you have Microsoft Dynamics NAV SDK installed, replace the following files.

File name

File version

File size

Date

Time

Platform

Cf.h

Not applicable

57,736

30-Aug-2010

12:11

Not applicable

Cfront.dll

6.0.31587.0

1,577,808

30-Aug-2010

16:28

x86

Cfront.ocx

6.0.31587.0

111,952

30-Aug-2010

16:28

x86

Cfrontsql.dll

6.0.31587.0

1,787,736

30-Aug-2010

16:28

x86

Libload.c

Not applicable

31,718

30-Aug-2010

06:51

Not applicable

Microsoft.dynamics.nav.cfront.cfrontdotnet.dll

6.0.31587.0

182,168

30-Aug-2010

16:10

x86

Microsoft.dynamics.nav.cfront.cfrontdotnet.xml

Not applicable

442,447

30-Aug-2010

07:12

Not applicable

Sample.c

Not applicable

28,718

30-Aug-2010

06:51

Not applicable

Sample.exe

6.0.31587.0

152,400

30-Aug-2010

16:28

x86

To replace the files, follow these steps.

  1. Locate the Microsoft Dynamics NAV SDK installation directories. The Microsoft Dynamics NAV SDK is usually installed in the following directories:

    C:\Program Files\Microsoft Dynamics NAV\60\SDK\CFRONT

    C:\Program Files\Microsoft Dynamics NAV\60\SDK\Communication Components

    C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication Component

  2. Choose the SDK to update, either C/Front or Communication Components.

  3. Copy the files that you downloaded.

  4. Paste the files that you downloaded into the appropriate Microsoft Dynamics NAV SDK installation directory.

  5. Click Yes to overwrite the files in the directory.

Note If you downloaded a hotfix or an update for the communication components, you must register the .dll files individually.

Step 6: Replace the files in the Microsoft Dynamics NAV ODBC driver installation

If you have the Microsoft Dynamics NAV ODBC driver installed, replace the following files in the Microsoft Dynamics NAV ODBC driver installation.

File name

File version

File size

Date

Time

Platform

Cfront.dll

6.0.31587.0

1,577,808

30-Aug-2010

16:28

x86

Dbm.dll

6.0.31587.0

427,848

30-Aug-2010

16:28

x86

Nc_netb.dll

6.0.31587.0

96,592

30-Aug-2010

16:28

x86

Nc_tcp.dll

6.0.31587.0

98,640

30-Aug-2010

16:28

x86

Nc_tcps.dll

6.0.31587.0

141,136

30-Aug-2010

16:28

x86

Nodbc.dll

6.0.31587.0

2,141,008

30-Aug-2010

16:28

x86

Nodbc.xml

Not applicable

1,209

25-Aug-2009

16:43

Not applicable

Nodbccfg.cfg

6.0.31587.0

724,480

30-Aug-2010

08:05

Not applicable

Nodbccfg.xml

Not applicable

2,472

25-Aug-2009

16:43

Not applicable

Slave.exe

6.0.31587.0

152,400

30-Aug-2010

16:28

x86

To replace the files, follow these steps.

  1. Locate the Microsoft Dynamics NAV ODBC driver installation directory. The Microsoft Dynamics NAV ODBC driver is usually installed in the following directory:

    C:\Program Files\Microsoft Dynamics NAV\60\ODBC

  2. Copy the files that you downloaded.

  3. Paste the files that you downloaded into the Microsoft Dynamics NAV ODBC driver installation directory.

  4. Click Yes to overwrite the files in the directory.

Prerequisites

You must have Microsoft Dynamics NAV 2009 Service Pack 1 installed to apply this hotfix.

Workaround

To work around this problem, define a layout for the reports that are run in quick succession from the RTC. If the report layout is defined, the RTC will run the report by using its own report engine. Therefore, the RTC does not start multiple sessions of the classic report engine.

Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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