Applies To
Microsoft Dynamics CRM 2011 Dynamics CRM 4.0

Symptoms

After removing either the Site or Customers fields from the Service Activity form, the following error will occur when trying to schedule activities:Microsoft CRM Error Report:Error Description:An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.Error Details:Exception of type 'System.Web.HttpUnhandledException' was thrown.Full Stack:[KeyNotFoundException: The given key was not present in the dictionary.]   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)   at Microsoft.Crm.Application.Dialogs.SM.ActivitySchedulingDialog.SetCustomizableLabel(FormDescriptor formDescriptor, EntityMetadata serviceActivityMetadata, String attributeName, FormCell formCell)   at Microsoft.Crm.Application.Dialogs.SM.ActivitySchedulingDialog.SetCustomizableLabels()   at Microsoft.Crm.Application.Dialogs.SM.ActivitySchedulingDialog.ConfigureForm()   at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)   at System.Web.UI.Control.PreRenderRecursiveInternal()   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)[HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.]   at System.Web.UI.Page.HandleError(Exception e)   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)   at System.Web.UI.Page.ProcessRequest()   at System.Web.UI.Page.ProcessRequest(HttpContext context)   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) 

Cause

The Site and Customer fields are required by the Scheduling engine to be on the Service Activity form

Resolution

Add the Site and Customers fields back to the Service Activity form and publish customizations

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