Applies ToWindows Server 2008 Datacenter without Hyper-V Windows Server 2008 Enterprise without Hyper-V Windows Server 2008 Standard without Hyper-V Windows Server 2008 Datacenter Windows Server 2008 Enterprise Windows Server 2008 Standard Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Standard

Symptoms

Consider the following scenario:

  • You install the Active Directory Domain Services (AD DS) role on a computer that is running Windows Server 2008 or Windows Server 2008 R2.

  • A Lightweight Directory Access Protocol (LDAP) client supports SASL Digest-MD5 subsequent authentication and sends an authentication request using the SASL Digest-MD5 authentication mechanism.

  • However, Active Directory Domain Services (AD DS) does not support subsequent authentication when the Digest-MD5 Simple Authentication and Security Layer (SASL) authentication mechanism is used, but still indicates that it does to the client.

In this scenario, the LDAP client authentication request fails.

Cause

Active Directory Domain Services (AD DS) does not support subsequent authentication when the Digest-MD5 Simple Authentication and Security Layer (SASL) authentication mechanism is used.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

  • Windows Server 2008 R2

Additionally, the computer must have the Active Directory Domain Services (AD DS) role installed. For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 file information notes

Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.0.600 1. 22xxx

    Windows Server 2008

    RTM

    LDR

    6.0.600 2. 22xxx

    Windows Server 2008

    SP2

    LDR

  • Service Pack 1 is integrated into the release version of Windows Server 2008.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Ntdsai.dll

6.0.6001.22541

1,950,720

14-Oct-2009

15:07

x86

Ntdsai.dll

6.0.6002.22245

1,950,720

14-Oct-2009

14:11

x86

For all supported x64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Ntdsai.dll

6.0.6001.22541

2,635,776

14-Oct-2009

15:08

x64

Ntdsai.dll

6.0.6002.22245

2,635,776

14-Oct-2009

14:26

x64

Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.1.760 0. 21xxx

    Windows Server 2008 R2

    RTM

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Ntdsa.mof

Not Applicable

227,765

10-Jun-2009

20:34

Not Applicable

Ntdsai.dll

6.1.7600.21061

2,726,400

30-Sep-2011

07:23

x64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

X86_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.0.6001.22541_none_f125a6e9d25fe220.manifest

Not Applicable

12,574

14-Oct-2009

16:56

Not Applicable

X86_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.0.6002.22245_none_f31019f9cf829ca0.manifest

Not Applicable

12,574

14-Oct-2009

15:30

Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Amd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.0.6001.22541_none_4d44426d8abd5356.manifest

Not Applicable

12,632

14-Oct-2009

16:57

Not Applicable

Amd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.0.6002.22245_none_4f2eb57d87e00dd6.manifest

Not Applicable

12,632

14-Oct-2009

16:12

Not Applicable

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_0a42936db200cbe5c4b36d51372fb3d2_31bf3856ad364e35_6.1.7600.21061_none_11367a0df37447da.manifest

File version

Not Applicable

File size

716

Date (UTC)

30-Sep-2011

Time (UTC)

19:52

Platform

Not Applicable

File name

Amd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.1.7600.21061_none_4d5650aeebe4f2d7.manifest

File version

Not Applicable

File size

3,531

Date (UTC)

30-Sep-2011

Time (UTC)

07:57

Platform

Not Applicable

File name

Update.mum

File version

Not Applicable

File size

2,350

Date (UTC)

30-Sep-2011

Time (UTC)

19:52

Platform

Not Applicable

References

For more information about the Simple Authentication and Security Layer (SASL) authentication, visit the Microsoft Web site:

http://msdn.microsoft.com/en-us/library/cc223500(PROT.10).aspxFor more information about DIGEST-MD5 subsequent authentication implementation (2.1.3), visit the following Internet Engineering Task Force (IETF) Web site:

http://www.ietf.org/rfc/rfc2831.txtMicrosoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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