Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

In a Microsoft Skype for Business Server 2019 environment, when you try to join a Skype meeting from Google Chrome by using the meeting link, you may receive the following error message:
The webpage at MeetingLink might be temporarily down or it may have moved permanently to a new web address.

Cause

The issue occurs because the Skype for Business Server certificates don't support certificate transparency as required by Google Chrome version 69 or a later version of version 69.

Resolution

To fix this issue, please make sure that Skype for Business Server certificates support certificate transparency. You could contact your Certification Authority (CA) provider to receive the support for certificate transparency.


Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×