Applies ToWindows Vista Enterprise Windows Vista Home Basic Windows Vista Home Premium Windows Vista Starter Windows Vista Ultimate Windows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate

Symptoms

You receive errors, or nothing happens when you start an .EXE file in Windows 7 or Windows Vista. Additionally, you may receive messages saying that you have a virus.

Cause

This issue can occur if a virus or other 3rd party application has changed or corrupted some default registry settings.

Resolution

To resolve this issue, you can reset the registry settings to their default settings. To do this, follow these steps.

  1. Click the Startbutton and type regedit in the Search box

  2. Right-click Regedit.exe in the returned list and click Run as administrator

  3. Browse to the following registry key: HKEY_CLASSES_ROOT\.exe

  4. With .exe selected, right-click (Default) and click Modify…

  5. Change the Value data: to exefile

  6. Browse to and then click on the following registry key: HKEY_CLASSES_ROOT\exefile

  7. With exefileselected, right-click (Default) and click Modify…

  8. Change the Value data: to "%1" %*

  9. Browse to and then click on the following registry key: KEY_CLASSES_ROOT\exefile\shell\open

  10. With openselected, right-click (Default) and click Modify…

  11. Change the Value data: to "%1" %*

  12. Close the Registry Editor and restart your PC

More Information

If this does not resolve your issue, or clicking .EXE files starts the incorrect application, see this article:

When you run an .exe file on a Windows based computer, the file may start a different program

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.