Applies ToWindows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate

Symptoms

You upgrade your computer from an earlier version of Windows to Windows 7 or to Windows Server 2008 R2. Then, a third-party application that uses Citrix DNE, does not work with the native Windows 7 Mobile Broadband driver. Notes

  • An example of a third-party application is a virtual private network (VPN).

  • This issue occurs only when you use a Network Driver Interface Specification (NDIS) intermediate driver, such as Citrix DNE, together with the native Windows 7 Mobile Broadband driver. Devices that use legacy NDIS drivers are not affected.

Cause

The current release of Citrix DNE is an NDIS intermediate driver that is based on NDIS 5.0. However, the native Windows 7 Mobile Broadband driver and compatible devices are based on NDIS 6.2. Earlier intermediate drivers that are based on NDIS 4.x or on NDIS 5.x have a known compatibility issue with the native Windows 7 Mobile Broadband driver.

Workaround

You can update your NDIS intermediate driver to NDIS 6.x-based Light Weight Filter (LWF). 

More Information

Citrix DNE

For more information about Citrix DNE, visit the following Citrix Web site:

http://www.citrix.com/lang/English/lp/lp_1680845.asp

Compatible VPN clients

For more information about third-party VPN clients that work on Windows 7, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/library/dd787668(WS.10).aspx

Mobile Broadband

To check whether your Mobile Broadband device is compatible with the native Windows 7 Mobile Broadband driver, visit the following Microsoft Web site:

Windows 7 Compatibility CenterTo check whether you are using the native Windows 7 Mobile Broadband driver,

click Start start button , type ncpa.cpl in the search box, and then press ENTER. If you are using the native Mobile Broadband driver and a device is connected, you see an adapter that is displayed as "Mobile Broadband."The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.