Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Microsoft COM+ applications that run on a Windows Server 2008-based computer freeze because a deadlock condition occurs in the COM+ System Application service. This issue occurs when the COM+ applications are set to recycle based on the Application Recycling options in the com+ application properties.

Cause

This issue occurs because a race condition occurs in the system application that involves calls to the DeleteTimerQueueTimer method. Therefore, the COM+ applications that call into the COM+ System Application service may freeze.

Resolution

To resolve this issue, install the hotfix that is described in this article.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 SP2.
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

948465 Information about Service Pack 2 for Windows Vista and for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Vista and Windows Server 2008 file information and notesImportant Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista/Windows Server 2008" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Catsrvut.dll

2001.12.6932.23372

489,472

09-Apr-2014

03:55

x86

Comsvcs.dll

2001.12.6932.23372

1,210,880

09-Apr-2014

03:56

x86

For all supported x64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Catsrvut.dll

2001.12.6932.23372

532,480

09-Apr-2014

04:34

x64

Comsvcs.dll

2001.12.6932.23372

1,688,064

09-Apr-2014

04:34

x64

Catsrvut.dll

2001.12.6932.23372

489,472

09-Apr-2014

03:55

x86

Comsvcs.dll

2001.12.6932.23372

1,210,880

09-Apr-2014

03:56

x86

For all supported IA-64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Catsrvut.dll

2001.12.6932.23372

1,220,096

09-Apr-2014

03:18

IA-64

Comsvcs.dll

2001.12.6932.23372

3,227,648

09-Apr-2014

03:18

IA-64

Catsrvut.dll

2001.12.6932.23372

489,472

09-Apr-2014

03:55

x86

Comsvcs.dll

2001.12.6932.23372

1,210,880

09-Apr-2014

03:56

x86



Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates.

Additional file information

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×