Delay experienced when you open a Skype for Business conversation from Outlook

Symptoms

If you open a conversation history item in Microsoft Outlook that contains many chat items, and try to start a Skype for Business conversation, it can take a long time for the conversation to appear.

Cause

When creating the conversation window in this scenario, Skype for Business tries to process each chat item to add it into the conversation window as chat history. This process can take some time when there are many chat history items.

Resolution

To fix this issue, make sure that the client version is higher than 16.0.13901.20230.

Note This solution requires limiting the number of chat items loaded into the conversation window. This number must be configured by a policy using one of the following options. In this example, we are limiting the number to 20 items.

  1. Create the following registry key on the client computers:

    Root: HKEY_LOCAL_MACHINE or HKEY_CURRENT_USER
    Key: Software\Policies\Microsoft\Office\16.0\Lync
    Value Type: DWORD
    Value Name: MaxHistoryItemsToLoad 
    Value Data: 0x00000014 (Hexadecimal)

  2. Create the following client policy entry by using the Skype for Business PowerShell:

    $x = New-CsClientPolicyEntry -Name "MaxHistoryItemsToLoad" -Value "20"
    Set-CsClientPolicy -Identity "<ClientPolicyName>" -PolicyEntry @{Add=$x}

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