Symptoms
The Microsoft Dynamics SL client installation process hangs while Installing Data Access Components.
Cause
Cause 1:
The version of MDAC on the workstation is older than version 2.5 and the Microsoft Dynamics SL installer is trying to update the MDAC components.
See Resolution 1.
Cause 2:
When the Microsoft Dynamics SL installer executing sqlredis.exe to install the SQL Server Client Connectivity Components, the process hangs on one of the components being installed.
See Resolution 2.
Resolution
Resolution 1:
To resolve this issue, execute the following steps:
1. First, verify the version of MDAC that is installed. To do this, use the following steps:
a. Click Start | Run
b. Type "Regedit"
c. In the registry, browse to HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess
d. Look for the "version" key.
e. Check to see if this key is less than 2.50.4403.12.
f. If it is, you can try manually installing the MDAC components from the following website:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&displaylang=en
NOTE:
If the key is missing, this could mean a problem with the Operating System and it may need to be reinstalled.
If the key is present and is greater than 2.50.4403.12, this is likely not the cause of your issue.
Resolution 2:
If sqlredis.exe or one of the executables it uses is hanging, you may end them in Task Manager:
1. Press Ctrl+Alt+Del and launch Task Manager.
2. On the Processes Tab, look for one of the following processes:
setupre.exe
sqlredis.exe
dasetup.exe
3. If any of the above executables is listed on the "Processes" tab, end the process. If successful, the installer should proceed to the next step of the client installation.