Error message in Microsoft Dynamics NAV: You do not have permissions to read the [TableName] table

Microsoft Business Solutions-Navision 4.0 and Microsoft Navision 4.0 are now part of Microsoft Dynamics NAV 4.0. All references to Microsoft Business Solutions-Navision or to Microsoft Navision 4.0 pertain to Microsoft Dynamics NAV.

Symptoms

On a computer that is running Microsoft Dynamics NAV, you may receive the following error message:

You do not have permissions to read the [TableName] table. Contact your system manager if you need to have your permissions changed.

Note The [TableName] in the error message can be the name of any table in Microsoft Dynamics NAV.

Cause

This problem occurs because Microsoft Dynamics NAV checks the permissions for any table that is accessed manually or by using C/AL code. This verification occurs even if the tables are not used or are empty.

Note This problem does not occur in versions that are earlier than Microsoft Dynamics NAV 4.0.

Resolution

To resolve this problem, give the user Read permission for the tables. Do this even for the tables that are not used. To do this, follow these steps:

  1. On the Tools menu, click Security, click Roles, and then click Permissions.



    The Permission table appears.

  2. Under the Object Type column, select Table Data.

  3. Under the Object ID column, type the table number.

  4. Make sure that "Yes" appears only next to the following permissions:

    1. Read Permission

    2. Execute Permission

    Note Delete "Yes" from all other permissions.

  5. Close the table.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×