Symptoms
Consider the following scenario. You are installing Business Portal for Microsoft Dynamics GP 10.0 or later versions. In the Select Features window, you select features that you want to install. In this scenario, you receive the following error message:
The following selected items are not registered or are not installed in the back office.
Note This message states that Business Portal and other modules are not registered even though the modules are registered.
Cause
This problem occurs because the GPReg.dll file is corrupted.
Resolution
If the Dexterity Shared Components 10.0 or 11.0 are not installed
To resolve this problem, install the Dexterity Shared Components 10.0 or 11.0 on the server that is running Business Portal. To do this, follow these steps:
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Double-click the DexterityCommonFiles.msifile.
Note This file is in the following location on the Microsoft Dynamics GP 10.0 or 11.0 DVD:Bin\DexCmn
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In the License Agreement window, click I accept the terms in the License Agreement, and then click
Install. -
Click Finish when the installation is complete.
If the Dexterity Shared Components 10.0 are installed
To resolve this problem, run the repair process for the Dexterity Shared Components 10.0 or 11.0 on the server that is running Business Portal. To do this, follow these steps:
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Click Start, click Control Panel, and then click Add or Remove Programs.
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Click Dexterity Shared Components 10.0 or Dexterity Shared Components 11.0, and then click
Change. -
Click Repair to begin the repair process.
More Information
If you receive an error message that states that the Microsoft .NET Framework 2.0 is not installed when you try to install the Dexterity Shared Components, click the following article number to view the article in the Microsoft Knowledge Base:
947538 Error message when you try to install Microsoft Dynamics GP 10.0: "Product: Dexterity Shared Components -- .NET Framework 2.0 is not installed. The installation cannot continue"