Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

SYMPTOMS

When you install an eConnect hotfix on a computer that is running Microsoft SQL Server 2005 together with Microsoft Dynamics GP, you receive the following error message:

Error Number = -2147217900 Error Description = The default trace cannot be stopped or modified. Use SP_CONFIGURE to turn it off. Error Source = Microsoft OLE DB provider for SQL ServerLine Number = 830.

CAUSE

This problem occurs because the Default Trace option is enabled in Microsoft SQL Server 2005. Therefore, the hotfix installation fails.

Note The Default Trace option provides troubleshooting assistance to database administrators.

RESOLUTION

To resolve this problem, run the following statement to disable the trace. After you disable the trace, you can install the hotfix. sp_configure 'default trace enabled', 0 go reconfigure go Note In the statement, the 0 parameter disables the trace feature.

To enable the trace after you install the hotfix, run the following statement. sp_configure 'default trace enabled', 1 go reconfigure go Note In the statement, the 1 parameter enables the trace feature.

MORE INFORMATION

To reproduce this problem, run the following statement to enable the trace. Then, install an eConnect hotfix. sp_configure 'default trace enabled', 1 go reconfigure go

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×