Symptoms
When you post a payables batch or computer check batch in Payables Management in Microsoft Dynamics GP in a multi-lingual environment, you receive the following error message.
A get/change operation on table 'SY_Transaction_Source_MSTR' could not find a record.
Note This message may happen at a workstation for a different language, and the US based installation does not produce the error message.
Cause
The multi-lingual workstation is checking the SY_Transaction_Source_MSTR (SY01000) table for an Audit Trail code that does not exist, due to the language difference.
All the audit trail codes are based on the original server installation. So if a workstation has a different language, it may be checking the SY01000 table for an audit trail code of PMTRN or PMCHQ, for example, and they do not exist because the server has PMTRX or PMCHK as the audit trail code instead in the SY01000 table due to the language difference. All audit trail codes must be identitcal across companies.
Resolution
To resolve this issue, certain steps must be followed to synchronize the dictionaries across all companies. Be sure to follow the steps exactly as listed in Q8 (question #8) in KB 887108 below:
887108 Answers to Frequently Asked Questions about International installations of Microsoft Great Plains
http://support.microsoft.com/help/887108
And/or in 'Answer 4' of this blog article:
Multilingual installs in Microsoft Dynamics GP - what you need to know!!