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Rapidly Published articles provide information directly from within the Microsoft support organization. The information that is contained herein is created in response to emerging or unique topics, or is intended to supplement other Knowledge Base information.

This article applies to Microsoft Dynamics NAV for all countries and all language locales.

Symptoms

After you use the Get Shipment Lines function two times to split a sales invoice into two lines for a lot tracked item in Microsoft Dynamics NAV, you post the sales invoice. However, you receive the following error message:

Tracking specification entry no Number already exists.


Note Number is a placeholder for the actual tracking specification entry number.

This problem occurs in the following products:

  • Microsoft Dynamics NAV 2009

  • Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)

  • Microsoft Dynamics NAV 5.0 SP1

  • Microsoft Dynamics NAV 5.0

Cause

This problem occurs because two item tracking specification lines with the same entry number are inserted during the sales invoice posting.

Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is only intended to correct the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Dynamics NAV service pack or the next version that contains this hotfix.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.



Installation information

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.

Note Before you install this hotfix, verify that all Microsoft Navision client users are logged off the system. This includes Microsoft Navision Application Services (NAS) client users. You should be the only client user who is logged on when you implement this hotfix.

To implement this hotfix, you must have a developer license.

We recommend that the user account in the Windows Logins window or in the Database Logins window be assigned the "SUPER" role ID. If the user account cannot be assigned the "SUPER" role ID, you must verify that the user account has the following permissions:

  • The Modify permission for the object that you will be changing.

  • The Execute permission for the System Object ID 5210 object and for the System Object ID 9015 object.



Note You do not have to have rights to the data stores unless you have to perform data repair.

Code changes

Note Always test code fixes in a controlled environment before you apply the fixes to your production computers.

To install this hotfix, change the code in the SaveInvoiceSpecification function in the Sales-Post codeunit (80) as follows:

Existing code

 TempInvoicingSpecification."Quantity Invoiced (Base)" += TempInvoicingSpecification."Qty. to Invoice (Base)";
TempTrackingSpecification := TempInvoicingSpecification;
TempTrackingSpecification."Buffer Status" := TempTrackingSpecification."Buffer Status"::MODIFY;
// Delete the following line.
TempTrackingSpecification.INSERT;

UNTIL TempInvoicingSpecification.NEXT = 0;
TempInvoicingSpecification.DELETEALL;
END;

Replacement code

 TempInvoicingSpecification."Quantity Invoiced (Base)" += TempInvoicingSpecification."Qty. to Invoice (Base)";
TempTrackingSpecification := TempInvoicingSpecification;
TempTrackingSpecification."Buffer Status" := TempTrackingSpecification."Buffer Status"::MODIFY;
// Add the following lines.
IF NOT TempTrackingSpecification.INSERT THEN BEGIN
TempTrackingSpecification.GET(TempInvoicingSpecification."Entry No.");
TempTrackingSpecification."Qty. to Invoice (Base)" += TempInvoicingSpecification."Qty. to Invoice (Base)";
IF TempInvoicingSpecification."Qty. to Invoice (Base)" = TempInvoicingSpecification."Quantity Invoiced (Base)" THEN
TempTrackingSpecification."Quantity Invoiced (Base)" += TempInvoicingSpecification."Quantity Invoiced (Base)"
ELSE
TempTrackingSpecification."Quantity Invoiced (Base)" += TempInvoicingSpecification."Qty. to Invoice (Base)";
TempTrackingSpecification."Qty. to Invoice" += TempInvoicingSpecification."Qty. to Invoice";
TempTrackingSpecification.MODIFY;
END;
// The end of the lines.
UNTIL TempInvoicingSpecification.NEXT = 0;
TempInvoicingSpecification.DELETEALL;
END;

Prerequisites

You must have one of the following products installed to apply this hotfix:

  • Microsoft Dynamics NAV 2009

  • Microsoft Dynamics NAV 2009 SP1

  • Microsoft Dynamics NAV 5.0 SP1

  • Microsoft Dynamics NAV 5.0

Removal information

You cannot remove this hotfix.

More Information

For more information about the same problem on the purchase side in Microsoft Dynamics NAV 4.0, click the following article number to view the article in the Microsoft Knowledge Base:

934145 Error message when you post an invoice that has a lot number in Microsoft Dynamics NAV 4.0: "Tracking Specification Entry No. '[Number]' already exists"

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON-INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

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