Applies To
Microsoft Dynamics AX 4.0 Axapta Object Server

Symptoms

When you try to start the Microsoft Dynamics AX 4.0 client, you receive the following error message:

Failed to Establish Connection

Cause

This problem can have any of the following causes:

  • The Application Object Server (AOS) service is not running. See Resolution 1 in the "Resolution" section.

  • The Microsoft Dynamics AX client is not configured to use the correct TCP/IP port. See Resolution 2 in the "Resolution" section.

  • The version of the AOS service does not match the version of the Microsoft Dynamics AX client. See Resolution 3 in the "Resolution" section.

  • The client workstation does not have network access. Or, the client workstation cannot connect to the AOS server. See Resolution 4 in the "Resolution" section.

  • The Microsoft Dynamics AX client is connected to a firewall or to multiple domains. See Resolution 5 in the "Resolution" section.

  • The local policy does not grant the "Access this computer from the network" right to the AOS clients in the same network. See Resolution 6 in the "Resolution" section.

Resolution

To resolve this problem, use the appropriate resolution.

Resolution 1

To resolve this problem, start the AOS service. To do this, follow these steps:

  1. Click Start, point to All Programs, point to Administrative Tools, and then click Services.

  2. Locate Microsoft Dynamics AOS (Application Object Server) service.

  3. If the service is not running, right-click the service, and then click Start. Note The AOS service name uses the following format:

    Dynamics Server$ instance-number AOS-instance-name

Resolution 2

To resolve this problem, verify that the Microsoft Dynamics AX Server Configuration utility is using the correct TCP/IP port. Then, verify that the correct port is used for the Microsoft Dynamics AX client. To do this, follow these steps:

  1. Click Start, point to All Programs, point to Administrative Tools, and then click Microsoft Dynamics AX Server Configuration Utility.

  2. Click the appropriate instance of the AOS server and the appropriate configuration.

  3. Click the Application Object Server tab.

  4. Verify that the port number in the TCP/IP Port box is correct, and then click OK.

  5. Click Start, point to All Programs, point to Administrative Tools, and then click Microsoft Dynamics AX Configuration Utility.

  6. Click the Connection tab.

  7. Note the TCP/IP port number. If the AOS server name and the port number are incorrect, type the correct AOS server name. Then, type the port number that you verified in step 4.

  8. Click OK.

Resolution 3

To resolve this problem, verify that the version of the AOS service matches the version of the Microsoft Dynamics AX client. To this, follow these steps:

  1. Locate the version of the Microsoft Dynamics AX client. To do this, follow these steps:

    1. On the Help menu, click About Microsoft Dynamics AX.

    2. Note the kernel version and the application version.

  2. Locate the version of the AOS service. To do this, follow these steps:

    1. Locate the Ax32Serv.exe file on the AOS server. Note By default, the Ax32Serv.exe file is in the following folder:

      C:\Microsoft Dynamics AX\40\Server\AX40SP1\Bin

    2. Right-click Ax32Serv.exe, and then click Properties.

    3. In the Properties dialog box, click Details.

    4. On the Details tab, note the version of the AOS service in the File Version field.

Resolution 4

To resolve this problem, follow these steps:

  1. Click Start, click Run, type cmd in the Open box, and then click OK.

  2. At the command prompt, run the following command.

    ping <computer name>

    If the command is unsuccessful or if the command does not return the correct values, the client workstation does not have network access.

Resolution 5

To resolve this problem, follow these steps. Note You must be a member of the Domain Admins Group to follow these steps.

  1. Click Start, point to Administrative Tools, point to Local Security Settings, point to Local Policies, and then click User Rights Assignment on the AOS.

  2. Click Access this computer from the network.

  3. Click to select the Define these policy settings check box.

  4. Add the users who you want to connect to the AOS, and add the user groups that you want to connect to the AOS.

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