FIM Certificate Management and problem with non-English characters when AntiXssLIbrary is used

FIM CM 2010 is configured with the workflow which sends notification emails which pulls user specific information from AD. Some User specific information contains Umlaut characters (ä, ö, ü) and the characters in the email got incorrectly re-formatted.

Example:

For example, the givenName = Töst
Email Text in the workflow is:

Dear {User!givenName},
your Secret is:
{Secret1}
Mit freundlichen Grüßen
CLM


The “ö” character in the email that user receives will be misinterpreted and the email the user with the givenName Töst starts with:

Dear Töst.


The same issue is with User!sn and User!Displayname

Symptoms

FIM CM 2010 uses AntiXssLIbrary to HTML-encode data that can be potentially unsafe and causes undesired misinterpretation of umlaut characters.

Cause

Disable usage of AntrXssLibrary by adding "!none" suffix to the email tags.

For example, use {User!givenName!none} instead of {User!givenName}

Resolution

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×