Symptoms

Consider the following scenario:

  • You have Microsoft Forefront Threat Management Gateway (TMG) 2010 Service Pack 1 (SP1) preinstalled on your computer.

  • TMG is configured to generate the daily summary data overnight.

In this scenario, the summary data is not created as expected. If you try to generate a report, the report is empty, and only the report template information is displayed. Additionally, you may receive the following Report Summary Generation Failure" message in the TMG Management console:

Description: The daily summary for day "dd/mm/yyyy" was not created. This may cause the report for this period to be inaccurate. Verify that no prior reporting configuration alerts exist, and that the reporting services on the designated Forefront TMG report server are running and accessible from all the array members. Use the source location 1001.105.7.0.9027.450 to report the failure. The failure is due to error: 0x80040e4d

Cause

When TMG is preinstalled, Sysprep.exe is run on the computer to generalize the installation. However, after the installation is generalized, certain parts of the TMG installation may not function as expected. To correct these issues, the IsaApplianceInit.exe application is run when TMG is first started. But when Service Pack 1 is part of the preinstallation package, the timing for configuring the credentials for SQL Server Reporting Services (SSRS) is affected. In this case, TMG and SSRS have different credentials, and this causes the problem that is described in the "Symptoms" section.

Resolution

To resolve this problem, install the service pack that is described in the following Microsoft Knowledge Base article:

2555840 Description of Service Pack 2 for Microsoft Forefront Threat Management Gateway 2010

Workaround

To work around this problem, reconfigure TMG Reporting Services to synchronize credentials between TMG and SSRS. To do this, follow these steps:

  1. Start Notepad.exe. To do this, click Start, click Run, type notepad in the Open box, and then click OK.

  2. Copy and paste the following code into the Notepad document:

    set root = CreateObject("FPC.Root")Set arr = root.GetContainingArrayWScript.Echo "Creating new Reporting Services configuration id"Dim newConfigIdSet TypeLib = CreateObject("Scriptlet.TypeLib") newConfigId = TypeLib.GuidnewConfigId = Left(newConfigId, Len(newConfigId)-2) newConfigId = newConfigId & "#fpcISA2010SP1"arr.Reports.ReportingServicesProperties.ReportingServicesConfigurationId = newConfigIdwscript.echo "Changing Reporting Services configuration id"arr.Savewscript.echo "Waiting for reload on array " & arr.namearr.WaitForReloadwscript.echo "Done reloading array " & arr.nameDim adStateOpenadStateOpen = 1Set cnn = CreateObject("ADODB.Connection")cnn.ConnectionString = "Provider=SQLOLEDB;Data Source='(local)\ISARS';Integrated Security=SSPI"cnn.OpenIf cnn.State <> adStateOpen Then    wscript.echo "Failed to open SQL connection: " & cnn.ConnectionStringEnd IfDim sqlCommandsqlCommand = "IF EXISTS(SELECT * FROM ISA_RS_Db.sys.database_principals WHERE name='ISA_RS_USER')" + vbCr + vbLfsqlCommand = sqlCommand + "    BEGIN" + vbCr + vbLfsqlCommand = sqlCommand + "        PRINT 'User already have a role on this db'" + vbCr + vbLfsqlCommand = sqlCommand + "    END" + vbCr + vbLfsqlCommand = sqlCommand + "ELSE" + vbCr + vbLfsqlCommand = sqlCommand + "    BEGIN" + vbCr + vbLfsqlCommand = sqlCommand + "        PRINT 'User does not yet have a role on this db, adding...'" + vbCr + vbLfsqlCommand = sqlCommand + "        EXEC ISA_RS_Db..sp_adduser 'ISA_RS_USER'" + vbCr + vbLfsqlCommand = sqlCommand + "        EXEC ISA_RS_Db..sp_addrolemember 'db_owner', 'ISA_RS_USER'" + vbCr + vbLfsqlCommand = sqlCommand + "    END" + vbCr + vbLfwscript.echo "Will execute " & vbCr & vbLf & sqlCommandSet rs = cnn.Execute(sqlCommand)cnn.CloseWScript.Echo "Done!"
  3. Save the file as "FixDailySum.vbs."

  4. On the TMG Report server, open an administrative command prompt, and then use the following command to run the script:

    cscript.exe FixDailySum.vbs

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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