Applies ToWindows Server 2008 Datacenter Windows Server 2008 Enterprise Windows Server 2008 Standard Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Standard

Symptoms

Consider the following scenario:

  • You have an enterprise that has a user account lockout threshold policy applied.

  • You create a new task in Task Scheduler. When you create the task, you select the Run whether user is logged on or not option, click to clear the Do not store password. The task will only have access to local computer resources check box, and then click OK to apply the settings.

  • You are prompted to provide the credentials of the user in whose context the task should run.

  • You provide an invalid password several times at the task scheduler authentication prompt.

In this scenario, the user account is unexpectedly locked out.  Note This problem may occur even though the lockout threshold is not reached. This problem may also occur after you update the user account of an existing task. This problem is related to the problem that is described in the following article in the Microsoft Knowledge Base:  

2548120 Account is incorrectly locked after you create or change multiple scheduled tasks in Windows 7, in Windows Server 2008 R2, in Windows Vista, or in Windows Server 2008 Note If you do not have update 2548120 installed, the account can be unexpectedly locked out in even fewer attempts to provide an invalid password.

Cause

very time that you provide an incorrect password for the single task scheduler authentication, the badPwdCount attribute is incremented incorrectly two times (or four times, if update 2548120 is not installed).

Resolution

To resolve this problem, apply the hotfix that is described in that article after you apply update 2548120.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix. If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.  

Prerequisites

To apply this hotfix, you must have Service Pack 2 for Windows Server 2008 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.  

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.  

Windows Server 2008 file information and notes

Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.  

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table. The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.  

    Version

    Product

    SR_Level

    Service branch

    6.0.600 2. 23xxx

    Windows Server 2008

    SP2

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Hashcleanup.exe

6.0.6002.23205

9,728

30-Aug-2013

01:31

x86

Taskeng.exe

6.0.6002.23205

171,520

30-Aug-2013

01:31

x86

Taskeng.mof

Not applicable

2,254

29-May-2013

13:50

Not applicable

Schedsvc.dll

6.0.6002.23205

602,624

30-Aug-2013

03:00

x86

Schedsvc.mof

Not applicable

2,250

29-May-2013

13:50

Not applicable

Wmicmiplugin.dll

6.0.6002.23205

346,112

30-Aug-2013

03:00

x86

For all supported x64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Hashcleanup.exe

6.0.6002.23205

10,240

30-Aug-2013

02:27

x64

Taskeng.exe

6.0.6002.23205

268,800

30-Aug-2013

02:28

x64

Taskeng.mof

Not applicable

2,254

15-Nov-2011

15:19

Not applicable

Schedsvc.dll

6.0.6002.23205

856,576

30-Aug-2013

04:08

x64

Schedsvc.mof

Not applicable

2,250

15-Nov-2011

15:19

Not applicable

Wmicmiplugin.dll

6.0.6002.23205

500,736

30-Aug-2013

04:09

x64

Schedsvc.mof

Not applicable

2,250

29-May-2013

13:50

Not applicable

Taskeng.exe

6.0.6002.23205

171,520

30-Aug-2013

01:31

x86

Taskeng.mof

Not applicable

2,254

29-May-2013

13:50

Not applicable

For all supported IA-64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Hashcleanup.exe

6.0.6002.23205

20,480

30-Aug-2013

01:08

IA-64

Taskeng.exe

6.0.6002.23205

523,264

30-Aug-2013

01:10

IA-64

Taskeng.mof

Not applicable

2,254

15-Mar-2011

06:01

Not applicable

Schedsvc.dll

6.0.6002.23205

1,418,240

30-Aug-2013

02:25

IA-64

Schedsvc.mof

Not applicable

2,250

15-Mar-2011

06:01

Not applicable

Wmicmiplugin.dll

6.0.6002.23205

986,624

30-Aug-2013

02:26

IA-64

Schedsvc.mof

Not applicable

2,250

29-May-2013

13:50

Not applicable

Taskeng.exe

6.0.6002.23205

171,520

30-Aug-2013

01:31

x86

Taskeng.mof

Not applicable

2,254

29-May-2013

13:50

Not applicable

Windows Server 2008 R2 file information and notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.1.760 1.22xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

D61d61c8-d73a-4eee-8cdd-f6f9786b7124.xml

Not applicable

3,188

10-Jun-2009

20:57

Not applicable

Schedsvc.dll

6.1.7601.22467

1,110,016

28-Sep-2013

02:32

x64

Schedsvc.mof

Not applicable

2,684

10-Jun-2009

20:57

Not applicable

Schedsvc.mof

Not applicable

2,684

09-Jul-2013

06:32

Not applicable

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

D61d61c8-d73a-4eee-8cdd-f6f9786b7124.xml

Not applicable

3,188

10-Jun-2009

21:02

Not applicable

Schedsvc.dll

6.1.7601.22467

1,775,104

28-Sep-2013

01:38

IA-64

Schedsvc.mof

Not applicable

2,684

10-Jun-2009

21:02

Not applicable

Schedsvc.mof

Not applicable

2,684

09-Jul-2013

06:32

Not applicable

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

See the terminology Microsoft uses to describe software updates.

Additional file information

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