Applies ToCommerce Server 2009 Enterprise Commerce Server 2009 Standard

Symptoms

Assume that you create a non-English Microsoft Commerce Server 2009 website that uses the Search Results Web Part of Commerce Server. Then, you search the site for Chinese characters. In this situation, the first and second pages of the search results may be blank.

Cause

The issue occurs because the Search Results Web Part does not display results correctly.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Commerce Server 2009 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Installation steps

If you use Microsoft Commerce Server 2009 together with SharePoint Server 2007, download and install the hotfix package that has the "CS2009RTM_KB2667666" label.

  • The "CS2009RTM_KB2667666" hotfix package contains the following files:

    • CS2009-KB2667666-x86.exe

    • Hotfix.txt

    • Source.zip

Notes

  • The installation file that you have to install depends on the version of SharePoint that is installed on the computer that is running Commerce Server.

  • You must use the local administrator account to install this hotfix, or you must run the hotfix by using the Run as Administrator command. If the computer is running Windows Vista, Windows Server 2008, or a later operating system, and if User Account Control (UAC) is enabled, we recommend that you use the Run as Administrator command.

After you run the installation file, use one of the following computer configurations to resolve the issue.

  • Configuration 1 If no sites are deployed, run the SharePoint Commerce Services Configuration Wizard to deploy the new site by using the updated MicrosoftCommerceWebParts.WSP solution file.

  • Configuration 2 If some sites are deployed, run the following stsadm command to deploy the updated Web solution package (WSP) file: stsadm -o upgradesolution -name microsoftcommercewebparts.wsp -filename MicrosoftCommerceWebParts.WSP -immediate -allowgacdeployment

  • Configuration 3 If Web Parts are customized by using the CommerceSharePointExtensibilityKit tool, follow these steps:

    1. Locate the updated source files in the source folder that is included in this hotfix package. The detailed file list for the Source.zip file is included in a table in the "File information" section.

    2. Use the updated file to replace the files that are in the CommerceSharePointExtensibilityKit folder, and then merge the changes to the code.

    3. Compile the assemblies for the Web Parts.

    4. Deploy the new MicrosoftCommerceWebParts.WSP file.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Commerce Server 2009

File name

File version

File size

Date

Time

Platform

microsoftcommercewebparts.wsp

Not applicable

716,121

26-Jan-2012

08:01

Not applicable

Microsoft.commerce.common.dll

1.0.20123.38

84,784

26-Jan-2012

07:25

x86

Microsoft.commerce.contracts.dll

1.0.20123.38

92,984

26-Jan-2012

07:25

x86

Microsoft.commerce.providers.dll

1.0.20123.38

691,000

26-Jan-2012

07:25

x86

Source.zip file for Microsoft Commerce Server 2009

File name

File size

Date

Time

Path

Searchcontroller.cs

16,727

21-Sep-2011

14:31

source\common\controllers

Crosssitescriptingencoder.cs

4,507

21-Sep-2011

14:31

source\sharepointcommon

Sharepointcommon.csproj

7,943

21-Sep-2011

14:31

source\sharepointcommon

Iquerylanguagewebpart.cs

849

21-Sep-2011

14:31

source\sharepointcommon\editorparts

Querylanguageeditorpart.cs

4,456

21-Sep-2011

14:31

source\sharepointcommon\editorparts

Searchresultspresenter.cs

39,427

26-Jan-2012

07:02

source\ui\search\presenters

Isearchresults.cs

5,851

21-Sep-2011

14:31

source\ui\search\views

Searchresultswebpart.cs

74,551

21-Sep-2011

14:31

source\ui\search\webparts\searchresults

Spsearchresultswebpart.cs

18,796

21-Sep-2011

14:31

source\ui\searchsharepoint\webparts\searchresults

Common.designer.cs

9,392

21-Sep-2011

14:31

source\wspdeployment\wspbuild\resources

Common.resx

9,113

21-Sep-2011

14:31

source\wspdeployment\wspbuild\resources

Searchresources.resx

35,440

21-Sep-2011

14:31

source\wspdeployment\wspbuild\resources

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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