FIX: Event ID 627 when you try to run a 32-bit APPC application on a 64-bit version of Host Integration Server 2013

Symptoms

You try to run a 32-bit Advanced Program-to-Program Communications (APPC) application on a server that's running Microsoft Host Integration Server 2013. If the server is running a 64-bit version of Host Integration Server 2013, the application does not run, and the following event may be logged in the Application log:

Event ID: 627
Source: SNA Server
Description:
Internal message routing error: process id pid, mhtype 1, msgtype 1

Cause

This problem occurs because the APPC application's instance of the Host Integration Server client/server interface (Snadmod.dll) tries to locate the Host Integration Server security groups in the following registry locations:

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Host Integration Server\AdminSecurityGroup
HKEY_LOCAL_MACHINE \Software\Wow6432Node\Microsoft\Host Integration Server\RuntimeSecurityGroup
However, these registry keys do not exist on 64-bit versions of Host Integration Server. Therefore, no access control lists (ACLs) are set on the semaphore object, and this causes the application failure.

Resolution

Cumulative update information

The fix that resolves this problem is included in Cumulative Update 2 for Host Integration Server 2013.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

After you apply this update, the Snadmod.dll file correctly checks the following registry keys to locate the Host Integration Server security groups during initialization of a 32-bit APPC application on a 64-bit version of Host Integration Server:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Host Integration Server\AdminSecurityGroup
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Host Integration Server\RuntimeSecurityGroup

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×