Symptoms
Assume that you install Microsoft BizTalk 2010 Accelerator for HL7 (BTAHL7) on a computer that is running Microsoft BizTalk Server 2010. In this situation, you may encounter the following issues.
Issue 1
After you apply hotfix 2607536 on the computer, an invalid ORU^R01 message can be processed successfully.
Issue 2
If BizTalk server receives an HL7 batch that contains an FHS segment after you apply hotfix 2732905 on the computer, you receive an error message that resembles the following:
Fatal error encountered in 2XDasm. Exception information is Object reference not set to an instance of an object.
Cause
The issue occurs because of regression issues in the hotfixes 2607536 and 2732905.
Resolution
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have BTAHL7 installed together with the following hotfixes installed in this order:
-
Hotfix 2564013
-
Hotfix 2607536
-
Hotfix 2702143
-
Hotfix 2713884
-
Hotfix 2732905
Note You can refer to the Readme.txt file of this hotfix for detailed information about how to install this hotfix. If any issue occurs that requires you to uninstall BTAHL7, uninstall BTAHL7 and then reinstall HL7 with all the hotfixes in the specified order.
Restart requirement
After you apply this hotfix, you may have to restart the computer. If you are not prompted to restart the computer, you must restart the BizTalk host instance services.
Hotfix replacement information
This hotfix does not replace a previously released hotfix.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
BizTalk 2010 Accelerator for HL7
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Microsoft.solutions.btahl7.pipelinecommon.dll |
3.9.568.2 |
91,080 |
14-Jan-2013 |
15:14 |
x86 |
Microsoft.solutions.btahl7.pipelinemessagecore.dll |
3.9.568.2 |
87,000 |
14-Jan-2013 |
15:14 |
x86 |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
For more information about the Service Pack and Cumulative Update list for BizTalk Server, click the following article number to view the article in the Microsoft Knowledge Base:
2555976 Service Pack and Cumulative Update list for BizTalk Server For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk hotfixes and Service Pack support