Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

The following problems occur in Microsoft Visual Studio 2008 Team Foundation Server (TFS).

Symptom 1

When you install Visual Studio 2008 Team Foundation Server by using a local account, you receive an "Error 28002" error message in the installation log. Additionally, TF213000 error messages that resemble the following messages appear in the application event log:

Error message 1

Microsoft Visual Studio 2008 Team Foundation Server - ENU: ***ERRORLOG EVENT*** : ERROR:Error 28002.An unknown error occurred.

Error message 2

Detailed Message: TF213000: A required user account could not be added during installation or repair of Team Foundation Server. The installation or repair failed with the following exception message: System.Runtime.InteropServices.COMException (0x80004005): Unspecified error

Symptom 2

When you try to add a local account to Visual Studio 2008 Team Foundation Server, you receive one or more of the following error messages:

Error message 1

TF30291: There was a problem on the server of unknown cause. See the Team Foundation Server event log for details.

Error message 2

Team Foundation Server could not resolve the user or group 'local account name'. The user or group might be a member of a different domain, or the server might not have access to that domain. Verify the domain membership of the server and any domain trusts.

Error message 3

TF50361: Argument factorValue is zero length, there must be at least one SID element. Parameter name: factorValue

Cause

Cause 1

This problem occurs because the installation cannot retrieve the identity of a local account.

Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Visual Studio 2008 Team Foundation Server Service Pack 1 installed to apply this hotfix.

Restart requirement

After you apply this hotfix, you do not have to restart the computer if no relative instance is used.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Microsoft.teamfoundation.s erver.dll

9.0.30729.4036

376,832

06-Feb- 2009

08:42

x86

Microsoft.teamfoundation.server.resources.d ll

9.0.30729.4036

106,496

06-Feb- 2009

08:42

x86

Microsoft.teamfoundation.server.resources.d ll

9.0.30729.4036

110,592

06-Feb- 2009

08:42

x86

Microsoft.teamfoundation.server.resources.d ll

9.0.30729.4036

118,784

06-Feb- 2009

08:42

x86

Microsoft.teamfoundation.server.resources.d ll

9.0.30729.4036

81,920

06-Feb- 2009

08:42

x86

Microsoft.teamfoundation.server.resources.d ll

9.0.30729.4036

94,208

06-Feb- 2009

08:42

x86

Microsoft.teamfoundation.server.resources.d ll

9.0.30729.4036

98,304

06-Feb- 2009

08:42

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×