Symptoms

After you install an update for Microsoft Exchange Server 2019, you may get incomplete results when you search for items in a mailbox.

Cause

During each Exchange Server upgrade, the Microsoft Search Foundation is reinstalled. Although this process is not always completed successfully, such a failure doesn't stop the Exchange Server upgrade from being completed.

In this situation, the upgraded server appears to be fully functional. However, several issues will affect the services that are associated with the Microsoft Search Foundation. For example, the Microsoft Exchange Search service is disabled, or the Noderunner.exe process is stopped. Because of these issues, the server that's running Exchange Server stops indexing mailbox items. If the indexing failure continues for an extended period, the mailbox items that aren't indexed will go into a permanent failure state.

At any time after the items go into this failure state, if the issues that affect the search processes are fixed, the server will resume indexing items. However, the server won’t try to index the items that went into a permanent failure state. Therefore, those items won’t appear in search results.

Resolution

Trigger the Exchange server to index the mailbox items that were not indexed before. To do this, run the following cmdlet:

Start-MailboxAssistant -Identity <mailbox ID> -AssistantName BigFunnelRetryFeederTimeBasedAssistant

Note In this cmdlet, replace <mailbox ID> with the name of the affected mailbox.

Notes: 

  • The name of the assistant that's used in the cmdlet (BigFunnelRetryFeederTimeBasedAssistant) is case-sensitive.

  • The cmdlet is available in Exchange Server 2019 cumulative update 11 and later versions.

This cmdlet does not address all index-related issues. It only reminds the Exchange Search service to index items that were never indexed and are in the NonIndexed state.

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