Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

After you deploy a custom image or a new installation of Windows to a Surface device, you may encounter one or more of the following issues:

  • Color Profile (Enhanced/sRGB) is missing in Display Settings or Action Settings.

  • The Gemalto eSIM firmware update reports Error Code 31 in Device Manager.

  • The Surface DTX Service doesn't start. If you try to manually start it, the service reports Error Code 1053.

  • The Surface USB Hub Firmware Update Service doesn't start. If you try to manually start it, the service reports Error Code 1053.

Cause

These issues can occur because the custom image or the new installation of Windows doesn't include the Visual C++ redistributable as part of the image. The Visual C++ redistributable is required for specific functionality in some Surface services.

Resolution

To resolve these issues, install the latest Visual C++ Redistributable for x86-based and x64-based Surface devices or include the Redistributable as part of your custom image or Windows installation.

For more information about the latest Visual C++ Redistributable, see the following article in the Microsoft Knowledge Base:

2977003 The latest supported Visual C++ downloads

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×