Symptoms
Consider the following scenario:
-
You deploy an on-premise Microsoft Lync Server 2010 or Microsoft Lync Server 2013 environment for an organization.
-
Mailboxes of users in the organization are hosted on Exchange Online.
-
There is no routing from an internal network to the Internet.
-
Lync Phone Edition for Aries telephones download and interpret a proxy auto-config (PAC) file.
In this scenario, Lync Phone Edition for Aries telephones only tries to directly connect to Exchange Web Service.
Cause
This issue occurs because an important error that occurs when the direct connection to Exchange Web Service fails does not trigger the use of the proxy connection.
Resolution
To resolve this issue, install one of the following cumulative updates: