Introduction

This March 2017 Preview of the Quality Rollup for Windows 8.1 and Windows Server 2012 R2 includes cumulative improvements in reliability in the .NET Framework 4.6 and 4.6.1. We recommend that you apply this quality rollup as part of your regular maintenance routines. Before you install this update, see the "Prerequisites" and "Restart requirement" sections.

Quality and reliability improvements

  • For SQL

    Exceptions may be thrown in SqlClient during prelogin handshake processing or during MARS communication when a received TDS packet's size is smaller than expected. Prelogin handshake errors will manifest as an OverflowException, and MARS errors will manifest as a generic "Physical connection is not usable" SqlException.

  • For WPF

    A WPF application with a virtualizing list control (ListBox, DataGrid, TreeView, and so on) can encounter an ArgumentNullException when you scroll to an item whose size has substantially decreased since the last time it was re-virtualized.

  • For ASP.NET

    In the following scenarios, ASP.NET may duplicate the cookie in a response header: 

    • Before the request cookie is loaded, a response cookie is added.

    • A response cookie is added, and then a native module sets the response cookie.

    With the fix, ASP.NET will make sure the response cookies are not duplicated.

  • For CLR

    When you use RSACng (or another class that directly or indirectly uses RSACng) to perform encryption by using RSAEncryptionPadding.Pkcs1 when the private key is stored on a smartcard (or other hardware security module), you experience the following exception:
     

    System.Security.Cryptography.CryptographicException: The parameter is incorrect at: System.Security.Cryptography.NCryptNative.DecryptData[T](SafeNCryptKeyHandlekey, Byte[] data, T& paddingInfo, AsymmetricPaddingMode paddingMode,NCryptDecryptor`1 decryptor)

How to get this update

For Windows 8.1 and Windows Server 2012 R2

This update is available by manual download only.

Manual download

To get the stand-alone package for this update, go to the Microsoft Update Catalog website.

Prerequisites

To apply this update, you must have the .NET Framework 4.6 or 4.6.1 installed.

Restart requirement

You have to restart the computer after you apply this update if any affected files are being used. We recommend that you close all .NET Framework-based applications before you apply this update.

Applies to

This article applies to the following:

  • Microsoft .NET Framework 4.6 and 4.6.1 when used with:

    • Windows Server 2012 R2

    • Windows 8.1

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Any additional feedback? (Optional)

Thank you for your feedback!

×