Sign in with Microsoft
Sign in or create an account.
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.


When you double-click or right-click the My Documents icon on the desktop, you may experience one or more of the following behaviors:

  • The My Documents folder does not open and no error message is displayed.

  • You receive any of the following error messages:

    • Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item.

    • The share name was not found. Be sure you typed it correctly.

    • The location you requested is not allowed as a target. Please choose a new location.


This behavior can occur if the My Documents folder has been redirected to a network share that has become unavailable.


To resolve this issue, verify that the network share is available, and then reestablish the connection to the share.


To work around this issue, redirect the My Documents folder to a local drive until the network share becomes available. However, if the shortcut is redirected to a local drive, then files stored on the network share are unavailable.

To redirect the My Documents folder to a local drive, follow these steps:

  1. Right-click the My Documents icon and then click Properties.

  2. On the Sharing tab, change the location from the network share to a local folder, and then click OK.


Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!