Applies ToDynamics CRM 2013

Symptom

Consider the following scenario:

  • You create a dialog for the contact entity in Microsoft Dynamics CRM 2013 from a computer that has Windows Internet Explorer 8 installed.Note Part of the dialog requirements is that CRM data is queried and presented as a picklist.

  • You add a Query CRM Data step when you create the dialog.

  • The filters of the query are dynamic (FirstName -> equals -> {FirstName(Contact)}).

  • The next step in the dialog is a Page that contains a Prompt and Response in which the promptis set to {FirstName(Contact)}, and the response is set to Option Set, in which the available options are populated from the query.

  • You run the dialog against a single contact record.

In this situation, there are no options available in the Prompt and Response option set.  

Cause

This issue occurs because Internet Explorer 8 causes a space to be added at the front of the values that are inserted into a query by using dynamics slugs.  

Resolution

To resolve this issue, you can use Windows Internet Explorer 9 to create and publish dialogs that contain CRM query steps.  

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.