Applies ToSkype for Business 2016

Symptoms

An Active Directory contact name is not displayed but the phone number is displayed in Microsoft Skype for Business 2016. This issue occurs when the following conditions are true:

  • An Active Directory contact contains a telephone number, an email address, and a full name.

  • You have set the EnableExchangeContactSync parameter to False or cleared the Sync contact info between Skype for Business and Exchange option in the Personal section of Options.

Cause

This is caused by a missed scenario to fetch the contact's display name.

Resolution

To fix this issue, install the November 7, 2017, update (KB4011238) for Skype for Business 2016, and then use one of the following settings to enable the update.

In-band provisioning setting

Run the following command from a Lync PowerShell command prompt:

$a = New-CsClientPolicyEntry -Name EnableContactResolutionWithTelUriAndEmailOnly -Value "true" Set-CsClientPolicy -IdentityGlobal -PolicyEntry @{Add=$a}

GPO setting

  1. In Group Policy Management, create a Group Policy object.Note When you create a GPO, specify a name and leave the source as none.

  2. On the Settings tab, right-click Computer Configuration or User Configuration, and then select Edit.

  3. Right-click Registry, select New, and then select Registry Item.

  4. In the New Registry Properties dialog box, specify the following information, and then select OK: Action: Create Hive: HKEY_CURRENT_USER Key path: Software\Policies\Microsoft\Office\16.0\Lync Value name: EnableContactResolutionWithTelUriAndEmailOnly Value type: REG_DWORD Value data: 1 Base: Decimal

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