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This article applies to: Surface Dock 2

Symptoms

In some cases, after you apply Surface Enterprise Management Mode (SEMM) for a Dock provisioning package to a Surface Dock 2 device, the Dock 2 seems not to authenticate as expected or seems to function slowly under the authenticated Dock policy.

In this situation, the condition persists until the host device is restarted or the Dock 2 is disconnected and reconnected.

Cause

This behavior is by design. Updates and transactions can seem to run slowly because the SEMM Dock policy and authorization are validated during enumeration. The Dock 2 firmware is updated before the policies are transmitted. Because this occurs in the background without any visual indication, authentication tasks can appear be delayed. Therefore, users have to either wait for the tasks to finish or they have to take some action on the host device to accelerate the process.

Workaround

To work around this behavior, either restart the host device or disconnect and reconnect the Dock 2.

More information

Dock provisioning that uses SEMM can seem to run slowly because, in part, the firmware queues up updates and transactions for each subsystem. This issue is most noticeable for initial production devices. After the Dock 2 is updated, provisioning seems to run much faster.

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