Problem: Hadoop verification script fails: 'Could not reserve enough space for object heap'

This error will occur if the system doesn't have enough available memory to create a Java virtual machine, that is needed to run a mapreduce job using a RxHadoopMR() compute context. This can happen if you have changed the memory settings for mapreduce for the following:

mapred.child.java.opts

mapred.child.java.ulimit

A workaround for the problem is to reset the setting for those options to the default in Cloudera Manager.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×