Symptoms

It takes a long time for the migration of public folder data from a single public folder database into multiple public folder mailboxes. This issue occurs in one of the following mixed environments:

  • Mixed environment of Microsoft Exchange Server 2007 and Microsoft Exchange Server 2013

  • Mixed environment of Microsoft Exchange Server 2010 and Exchange Server 2013

  • Mixed environment of Exchange Server 2007, Exchange Server 2010, and Exchange Server 2013

Additionally, when this issue occurs, you receive one or more of the following error messages. If the environment has Exchange Server 2007 as the source server, you receive an error message that resembles the following:

Batch migration for public folders from Exchange version {0}.{1} (Build {2}.{3}) isn't supported. You must first upgrade to Exchange 2007 SP3 RU15 or later (http://go.microsoft.com/fwlink/?LinkId=512477). Note that you must upgrade all servers hosting public folder databases and replicas in order for the migration to be successful.

If the environment has Exchange Server 2010 as the source server, you receive an error message that resembles the following:

Batch migration for public folders from Exchange version {0}.{1} (Build {2}.{3}) isn't supported. You must first upgrade to Exchange 2010 SP3 RU8 or later (http://go.microsoft.com/fwlink/?LinkId=512476). Note that you must upgrade all servers hosting public folder databases and replicas in order for the migration to be successful.

Cause

This issue occurs because Exchange only allows a single migration process to log into the public folder database at a time. It causes data migration to all the target mailboxes to be done one at a time.

Resolution

To resolve this issue, install the update rollup that is dated November 2014:

After you apply this update, Exchange is updated to let multiple migration processes log into the source public folder database immediately. This allows data migration to all the target mailboxes to be done in parallel. Load limiting will still apply, so you will not see all migration tasks working all at the same time.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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