Symptoms
Remote procedure call (RPC) data may be blocked by a computer that is running Microsoft Internet and Acceleration (ISA) Server 2004 or ISA Server 2000. When this problem occurs, some Microsoft Outlook clients may not start or may be unable to connect to the Microsoft Exchange server. When this behavior occurs, the affected clients receive one or more of the following error messages:
Task "Microsoft Exchange Server" reported error (0x80040115): "The connection to the Microsoft Exchange Server is unavailable. Outlook must be online or connected to complete this action."
Cannot start Microsoft Office Outlook
Unable to open the Outlook window.
The set of folders could not be opened.
Unable to open the Outlook window.
Note In Microsoft Small Business Server scenarios, this problem may occur when Outlook is installed on a server that is running Terminal Services in Application Sharing mode.
Cause
This problem may occur when the following conditions are true:
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The Outlook client computer is running Microsoft Windows Server 2003 with Service Pack 1 (SP1) or a 64-bit version of Microsoft Windows XP.
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The ISA Server computer resides between the client computer and a Microsoft Exchange server.
When you enable the RPC filter in ISA Server, the RPC filter enforces strict compliance with a subset of the RPC protocol that is used by Microsoft Exchange Server MAPI communications. However, the RPC filter in ISA Server is incompatible with the changes to the RPC protocol in Windows Server 2003 SP1 and in 64-bit versions of Windows XP.
Resolution
ISA Server 2004
Service pack information
To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024 How to obtain the latest ISA Server 2004 service pack
Hotfix Information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The following files are available for download from the Microsoft Download Center: ISA 2004, Enterprise Edition Download the ISA2004EE-KB897716-X86-ENU.msp package now. Release Date: May 26, 2005 For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file. ISA 2004, Standard Edition Download the ISA2004SE-KB897716-X86-ENU.msp package now. Release Date: May 26, 2005 For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
Prerequisites
To apply this hotfix, you must have one of the following versions of ISA Server 2004 installed:
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ISA Server 2004 Standard Edition with Service Pack 1 (SP1)
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ISA Server 2004 Enterprise Edition
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Date Time Version Size File name Edition
------------------------------------------------------------------ 20-Apr-2005 21:28 4.0.2163.263 133,392 Rpcfltr.dll Standard 14-May-2005 19:46 4.0.3440.263 129,816 Rpcfltr.dll EnterpriseISA Server 2000
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The following file is available for download from the Microsoft Download Center:Download the ISA2000-KB897716-X86-ENU.exe package now. Release Date: May 26, 2005 For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
Prerequisites
To apply this hotfix, you must have ISA Server 2000 Service Pack 2 (SP2) installed.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Date Time Version Size File name
----------------------------------------------------- 09-May-2005 16:15 3.0.1200.418 61,944 Rpcfltr.dllStatus
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.
More Information
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
885957 How to install ISA Server hotfixes and updates For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates