Symptoms
You have configured the Shared Line Appearance (SLA) feature in a Microsoft Skype for Business Server 2015 environment. When the SLA is called from an internal Skype for Business or Lync registered client (SIP-based), calls are forwarded to the configured forwarding destination successfully. However, when the SLA is called from a PSTN-based endpoint, calls are be routed to the PSTN number.
Cause
This issue occurs because the Skype for Business server can't locate the From user or PSTN number because the Outbound INVITE header lacks a Referred-By identity header.
Resolution
To fix this issue, install the July 2018 cumulative update 6.0.9319.534 for Skype for Business Server 2015, Front End Server and Edge Server.