This article applies to Microsoft Dynamics AX for all regions.
Symptoms
Assume that you upgrade from Microsoft Dynamics AX 2009 to Microsoft Dynamics AX 2012. When you run the "Accrued purchases" report, no purchase orders that were received in Microsoft Dynamics AX 2009 is displayed in the report. The report does not display upgraded purchase orders.
Cause
This problem occurs because the upgrade does not create ACCOUNTINGEVENT records. Therefore, the "Accrued purchases" report cannot interpret upgraded purchase orders.
Resolution
Hotfix information
A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website:
https://mbs.microsoft.com/support/newstart.aspx You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites: Partners
https://mbs.microsoft.com/partnersource/support/Customers
https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.
Installation information
If you have customizations for one or more of the methods or the tables that are affected by this hotfix, you must follow these steps:
-
Review the changes that are documented in the .xpo file.
-
Apply these changes in a test environment before you apply the hotfix in a production environment.
For more information about how to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
893082 How to install a Microsoft Dynamics AX hotfix
Prerequisites
You must have Microsoft Dynamics AX 2012 installed to apply this hotfix.
Restart requirement
You must restart the Application Object Server (AOS) service after you apply the hotfix.
File information
The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Aximpactanalysis.exe |
Not applicable |
60,280 |
07-Nov-2011 |
11:16 |
x86 |
Axupdate.exe |
Not applicable |
60,264 |
07-Nov-2011 |
11:16 |
x86 |
Dynamicsax2012-kb2713359-extensions.axmodel |
6.1.1108.802 |
16,168 |
15-May-2012 |
19:58 |
Not applicable |
Dynamicsax2012-kb2713359-foundation.axmodel |
6.0.1108.802 |
110,376 |
15-May-2012 |
19:58 |
Not applicable |
Dynamicsax2012-kb2713359-fpplabels.axmodel |
6.0.1108.802 |
194,856 |
15-May-2012 |
19:58 |
Not applicable |
Dynamicsax2012-kb2713359-syplabels.axmodel |
6.0.1108.802 |
850,216 |
15-May-2012 |
19:58 |
Not applicable |
Axsetupsp.exe |
6.0.947.853 |
1,361,768 |
16-Jan-2012 |
07:02 |
x86 |
Axutillib.dll |
6.0.947.0 |
817,512 |
11-Jul-2011 |
04:04 |
x86 |
Microsoft.dynamics.servicing.operations.dll |
6.0.888.436 |
35,752 |
09-Jun-2011 |
23:56 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
382,848 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
370,560 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
374,656 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
374,656 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
370,560 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
378,752 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
370,560 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
374,656 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
370,560 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
374,656 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
370,560 |
07-Nov-2011 |
11:16 |
x86 |
Axsetupsp.resources.dll |
6.0.947.491 |
407,424 |
07-Nov-2011 |
11:16 |
x86 |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.