Applies ToWindows 7 Service Pack 1 Windows 7 Enterprise Windows 7 Professional Windows 7 Ultimate Windows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard

Symptoms

Assume that you configure bandwidth throttling settings by using a Background Intelligent Transfer Service (BITS) Group Policy in an Active Directory domain environment. Then you perform transfers on a computer that is running Windows 7 Service Pack 1 or Windows Server 2008 R2 Service Pack 1.In this situation, when the second and subsequent transitions to a new bandwidth limit occur, these transitions are not applied to the ongoing transfers. Therefore, the transfers continue by using the previously specified bandwidth limitation until the process is complete.You can observe this behavior by monitoring the network traffic in Performance Monitor by using various counters in the following performance objects:

  • Network Adapter

  • Network Interface

  • BITS

Note Network-related performance counters cannot differentiate between the traffic that is produced by BITS and other generic network traffic. Therefore, to ensure reliabilitythe measurement must be made by configuring a minimal usage of network bandwidth for other network services. For example, no large file transfers should occur while the measurement is performed.

Cause

This problem occurs when during a bandwidth limitation transition because a work-item is scheduled in an internal queue that is handled by BITS. Work items are marked by using a time stamp. If the indicated time is checked during a particular time interval, a problem in BITS code causes the work item to mistakenly be considered as expired. The work item is then discarded. After this occurs, all subsequent transitions experience the same problem because each work item posts another work item for the next scheduled transition.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released hotfix.

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notesImportant Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.1.760 1. 22xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Qmgr.dll

7.5.7601.22365

585,216

20-Jun-2013

11:52

x86

Qmgr.mof

Not Applicable

2,302

10-Jun-2009

21:34

Not Applicable

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Qmgr.dll

7.5.7601.22365

848,896

20-Jun-2013

12:32

x64

Qmgr.mof

Not Applicable

2,302

10-Jun-2009

20:53

Not Applicable

Qmgr.mof

Not Applicable

2,302

12-Nov-2010

23:57

Not Applicable

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Qmgr.dll

7.5.7601.22365

1,772,544

20-Jun-2013

11:21

IA-64

Qmgr.mof

Not Applicable

2,302

10-Jun-2009

20:58

Not Applicable

Qmgr.mof

Not Applicable

2,302

12-Nov-2010

23:57

Not Applicable

Workaround

To work around this problem, stop all ongoing transfers, and then restart them in order for the current bandwidth limitation to be applied correctly. You must continually apply this workaround because each transition will experience the same problem.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

See the terminology Microsoft uses to describe software updates.

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

X86_d4adff77a931999d67726dd1e47f9d57_31bf3856ad364e35_6.1.7601.22365_none_634c1fb5b68f2060.manifest

File version

Not Applicable

File size

699

Date (UTC)

20-Jun-2013

Time (UTC)

18:30

Platform

Not Applicable

File name

X86_microsoft-windows-bits-client_31bf3856ad364e35_6.1.7601.22365_none_25ec9fd770f98b99.manifest

File version

Not Applicable

File size

113,723

Date (UTC)

20-Jun-2013

Time (UTC)

12:21

Platform

Not Applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

Amd64_8bba88c291ae225f44a2e22c63c62caa_31bf3856ad364e35_6.1.7601.22365_none_5a08e52b0a122be7.manifest

File version

Not Applicable

File size

1,048

Date (UTC)

20-Jun-2013

Time (UTC)

18:30

Platform

Not Applicable

File name

Amd64_microsoft-windows-bits-client_31bf3856ad364e35_6.1.7601.22365_none_820b3b5b2956fccf.manifest

File version

Not Applicable

File size

113,729

Date (UTC)

20-Jun-2013

Time (UTC)

13:06

Platform

Not Applicable

File name

Wow64_microsoft-windows-bits-client_31bf3856ad364e35_6.1.7601.22365_none_8c5fe5ad5db7beca.manifest

File version

Not Applicable

File size

53,420

Date (UTC)

20-Jun-2013

Time (UTC)

12:06

Platform

Not Applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_0abbeea722d640d1a41b0bcad830a50a_31bf3856ad364e35_6.1.7601.22365_none_91e0140e9a19db58.manifest

File version

Not Applicable

File size

1,046

Date (UTC)

20-Jun-2013

Time (UTC)

18:30

Platform

Not Applicable

File name

Ia64_microsoft-windows-bits-client_31bf3856ad364e35_6.1.7601.22365_none_25ee43cd70f79495.manifest

File version

Not Applicable

File size

113,726

Date (UTC)

20-Jun-2013

Time (UTC)

12:11

Platform

Not Applicable

File name

Wow64_microsoft-windows-bits-client_31bf3856ad364e35_6.1.7601.22365_none_8c5fe5ad5db7beca.manifest

File version

Not Applicable

File size

53,420

Date (UTC)

20-Jun-2013

Time (UTC)

12:06

Platform

Not Applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.