The Enable-Mailbox cmdlet doesn't block migrated users from provisioning in Exchange Server 2016

Symptoms

In a Microsoft Exchange Server 2016 hybrid environment, you could still run the Enable-Mailbox cmdlet against a remote mailbox that's already migrated to Microsoft Office 365, and provision a mailbox at the on-premise Exchange server.

Cause

This issue occurs because the validation is disabled.

Resolution

To fix this issue, install Cumulative Update 9 for Exchange Server 2016 or a later cumulative update for Exchange Server 2016.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology that Microsoft uses to describe software updates.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×