Symptoms

The Microsoft Exchange RPC Client Access service crashes intermittently on a Microsoft Exchange Server 2010 server. Additionally, the following event is logged:Notes

  • This issue typically occurs when a delegate of a mailbox accesses the mailbox, mailbox audit logging is enabled and the Microsoft Exchange Active Directory Topology service is stopped on the server.

  • When this issue occurs, clients cannot connect to the Exchange Server 2010 server.

Cause

This issue occurs because a System.InvalidOperationException exception occurs.

Resolution

To resolve this issue, install the following update rollup:

2579150 Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about mailbox audit logging, visit the following Microsoft website:

General information about mailbox audit logging

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.