The system prints the job card, the route job or the route card to the screen even though you specify the print option to print it to a printer during the release operation of a production order in Microsoft Dynamics AX 2012

This article applies to Microsoft Dynamics AX for all regions.

Symptoms

Assume that you select the Print job card check box, the Print route job check box or the Print route card check box on the General tab in the Release dialog box for a specific production order in Microsoft Dynamics AX 2012. Even though you set up the printer setting to a printer, the system prints the job card, the route job or the route card to the screen when you confirm the release of the production order. However, the system should print it to the printer.

Cause

This problem occurs because the three Setup buttons for print options on the ProdParmRelease form are not updated for setting the SQL Server Reporting Services (SSRS) report. 

Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website:

https:⁠//mbs.microsoft.com/support/newstart.aspx You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

Partners

https:⁠//mbs.microsoft.com/partnersource/support/ Customers

https:⁠//mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.

Installation information

If you have customizations for one or more of the methods or the tables that are affected by this hotfix, you must follow these steps:

  1. Review the changes that are documented in the .xpo file.
  2. Apply these changes in a test environment before you apply the hotfix in a production environment.

                
 For more information about how to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

893082 How to install a Microsoft Dynamics AX hotfix

Prerequisites

You must have Microsoft Dynamics AX 2012 installed to apply this hotfix.

Restart requirement

You must restart the Application Object Server (AOS) service after you apply the hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name File version File size Date Time Platform
Aximpactanalysis.exe Not applicable 60,280 06-Nov-2011 10:16 x86
Axupdate.exe Not applicable 60,264 06-Nov-2011 10:16 x86
Dynamicsax2012-kb2685154-foundation.axmodel 6.0.1108.142 17,320 03-Mar-2012 17:24 Not applicable
Dynamicsax2012-kb2685154-syplabels.axmodel 6.0.1108.142 796,584 03-Mar-2012 17:24 Not applicable
Axsetupsp.exe 6.0.947.853 1,361,768 15-Jan-2012 15:00 x86
Axutillib.dll 6.0.947.0 817,512 11-Jul-2011 00:48 x86
Microsoft.dynamics.servicing.operations.dll 6.0.888.436 35,752 15-Jun-2011 09:40 x86
Axsetupsp.resources.dll 6.0.947.491 382,848 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 374,656 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 374,656 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 378,752 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 374,656 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 374,656 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 370,560 06-Nov-2011 10:16 x86
Axsetupsp.resources.dll 6.0.947.491 407,424 06-Nov-2011 10:16 x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.