SYMPTOMS
When you use Extender Import in Microsoft Dynamics GP, the values in the list field are not imported.
CAUSE
This problem occurs because the file that contains the Extender list field data contains string values for the field instead of integer values for the field.
RESOLUTION
When you create a list in the Extender window, the EXT40102 table stores the list data. The string values in the list are stored in the LONGNAME column. The value in the LNITMSEQ column is the integer that corresponds to the string value in the list. The value in the Field_Number column is the field number for the list in the Extender window.
When you create the Extender data for the list, the EXT00103 table is populated. The value in the PT_UD_Number column is the field number in the "Extender setup" window. The value in the TOTAL column is the number in the list that you select. The value in the TOTAL column corresponds to the value in the LNITMSEQ column in the EXT40102 table.
When the file is created for the Extender import, import the LNITMSEQ column from the EXT40102 table. The values in the LNITMSEQ column correspond to the string values in the LONGNAME column.
MORE INFORMATION
Steps to reproduce the problem
You have a list that contains the following values:
• Red
• Yellow
• Green
If the string value of Yellow is contained in the Extender import file, you receive the error message. To import a value of Yellow, the Extender import file must contain an integer value of 2 instead of the string value of Yellow.